Bug 703928

Summary: Auto-upgrade from 13 to 14 couldn't install e1000e network driver.
Product: [Fedora] Fedora Reporter: Chris Carlson <cwcarlson>
Component: preupgradeAssignee: Richard Hughes <richard>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 14CC: anaconda-maint-list, jonathan, richard, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-16 11:18:59 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Chris Carlson 2011-05-11 13:37:43 EDT
Description of problem:
I attempted to allow the auto-upgrade tool to upgrade my F13 to F14.  All seemed good as it downloaded the upgrade files.  Performed reboot, and while coming up, it was unable to find a suitable network driver.  With F13, it uses the e1000e driver.  I tried to select the e1000e driver from the menu, but it was stuck in a loop requesting an appropriate driver.

I finally pushed the reset button, and the system booted back into my F13 version (which was a relief).


Version-Release number of selected component (if applicable):
Upgrade from F13 to F14.


How reproducible:
I haven't tried to reproduce as I need to work.  I will try again later.


Steps to Reproduce:
1. Popup offered to auto-upgrade.  I selected "More information."
2. Offered to download files.  I selected "OK."
3. Offered to reboot.  I selected "OK."
4. During bootup, indicated it was unable to find the appropriate driver for the network card.  I scrolled through options and selected the Intel e1000e driver (since I know this is used on F13).
5. At this point, it just keeps returning to tell me it can't find an appropriate driver.

  
Actual results:
Keeps requesting me to manually select an appropriate network driver.


Expected results:
Should automatically have found the appropriate network driver (F13 did when I installed it).  Alternatively, should have taken my manual selection and moved on with the installation.


Additional info:
The motherboard I am using is an "ASUS P5Q-EM D0."  No other additional hardware is installed.
Comment 1 Fedora End Of Life 2012-08-16 11:19:02 EDT
This message is a notice that Fedora 14 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 14. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained.  At this time, all open bugs with a Fedora 'version'
of '14' have been closed as WONTFIX.

(Please note: Our normal process is to give advanced warning of this 
occurring, but we forgot to do that. A thousand apologies.)

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, feel free to reopen 
this bug and simply change the 'version' to a later Fedora version.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we were unable to fix it before Fedora 14 reached end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" (top right of this page) and open it against that 
version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping