Bug 706222

Summary: Yum aborting with an error
Product: Red Hat Enterprise Linux 5 Reporter: Scott <wsmcintyre>
Component: yumAssignee: James Antill <james.antill>
Status: CLOSED NOTABUG QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 5.6   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-05-24 13:36:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Scott 2011-05-19 15:31:13 EDT
Description of problem:
Trying to install errata updates to all of my Linux VMs. Get the error described below on conflict between xen and xen-libs.  I've only managed to get the errata updates installed on one server by using 
  yum update --skip-broken
But the remainder of the servers this will not work.  Even tried to downgrade xen-libs. Same results.

Version-Release number of selected component (if applicable):
yum-3.2.22-33.el5

How reproducible:
Always (except one)

Steps to Reproduce:
1. yum clean all
2. yum update
3. Error!
  
Actual results:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xen-libs is needed by (installed) xen-3.0.3-105.el5_5.5.x86_64
xen-libs is needed by (installed) xen-3.0.3-105.el5_5.5.x86_64
Complete!

Expected results:
Errata updates installed.

Additional info:
Comment 1 Scott 2011-05-19 15:32:28 EDT
These VMs are running 64-bit RHEL 5.6 on a Citrix Xen server version 5.6.
Comment 2 James Antill 2011-05-19 16:27:37 EDT
It's likely that there is some pre-existing problem with xen/xen-libs in the rpmdb, which is why yum can't see it but rpm does. Check they they are installed, and have compatible versions etc. (package-clenaup --problems will help).
Comment 3 Scott 2011-05-23 15:38:10 EDT
I installed the yum-utils package and ran package-cleanup problems with the following results:

[root@hcc-webhead ~]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package xen requires xen-libs = 3.0.3-105.el5_5.5

When I try to downgrade xen-libs I get the following results:

[root@hcc-webhead ~]# yum downgrade xen-libs
Loaded plugins: rhnplugin, security
Setting up Downgrade Process
Resolving Dependencies
--> Running transaction check
---> Package xen-libs.i386 0:3.0.3-120.el5 set to be updated
---> Package xen-libs.x86_64 0:3.0.3-120.el5 set to be updated
---> Package xen-libs.i386 0:3.0.3-120.el5_6.1 set to be erased
---> Package xen-libs.x86_64 0:3.0.3-120.el5_6.1 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package       Arch        Version              Repository                 Size
================================================================================
Downgrading:
 xen-libs      i386        3.0.3-120.el5        rhel-x86_64-server-5      166 k
 xen-libs      x86_64      3.0.3-120.el5        rhel-x86_64-server-5      163 k

Transaction Summary
================================================================================
Remove        0 Package(s)
Reinstall     0 Package(s)
Downgrade     2 Package(s)

Total size: 329 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
xen-libs is needed by (installed) xen-3.0.3-105.el5_5.5.x86_64
xen-libs is needed by (installed) xen-3.0.3-105.el5_5.5.x86_64
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
[root@hcc-webhead ~]#

What's next?
Comment 4 James Antill 2011-05-24 13:36:52 EDT
You need to downgrade more than one version:

yum downgrade xen-libs-3.0.3-105.el5_5.5