Bug 706423

Summary: Network connection fails via USB cable to N900 phone
Product: [Fedora] Fedora Reporter: Henrik Nordström <henrik>
Component: ModemManagerAssignee: Dan Williams <dcbw>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: dcbw, neil.bryant, nik
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-07-18 18:55:57 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Henrik Nordström 2011-05-20 10:18:25 EDT
Description of problem:

Fails to establish Internet connection via USB cable to Nokia N900

Version-Release number of selected component (if applicable):

ModemManager-0.4-7.git20110201.fc15.x86_64

How reproducible:

Nearly always. Randomly works after restarting ModemManager

Steps to Reproduce:
1. Connect N900 via USB cable and select PC-Suite mode on the N900
2. Try to establish Internet connection
3.
  
Actual results:

Connection fails after some second

Expected results:

Working Internet connection

Additional info:

Same setup via Bluetooth works
Comment 1 Henrik Nordström 2011-05-20 10:18:58 EDT
Forgot to mention that it did work in F14.
Comment 2 Nik Lam 2011-05-22 03:12:49 EDT
I think I'm affected by the same thing. Here's the output in /var/log/messages when "Mobile broadband" in NetworkManager applet is switched from "off" to "on".


May 22 00:06:16 rtln4ge modem-manager[1123]: <info>  (ttyACM0) opening serial port...
May 22 00:06:16 rtln4ge modem-manager[1123]: <info>  Modem /org/freedesktop/ModemManager/Modems/1: state changed (disabled -> enabling)
May 22 00:06:20 rtln4ge modem-manager[1123]: <info>  Modem /org/freedesktop/ModemManager/Modems/1: state changed (enabling -> disabled)
May 22 00:06:20 rtln4ge modem-manager[1123]: <info>  (ttyACM0) closing serial port...
May 22 00:06:20 rtln4ge modem-manager[1123]: <info>  (ttyACM0) serial port closed
May 22 00:06:20 rtln4ge NetworkManager[1005]: <warn> failed to enable/disable modem: (32) Serial command timed out


[nme@rtln4ge ~]$ uname -a
Linux rtln4ge 2.6.38.6-27.fc15.x86_64 #1 SMP Sun May 15 17:23:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
[nme@rtln4ge ~]$ 

[nme@rtln4ge ~]$ rpm -qa | grep Manager
NetworkManager-openvpn-0.8.999-1.fc15.x86_64
ModemManager-0.4-8.git20110427.fc15.x86_64
NetworkManager-gnome-0.8.999-2.git20110509.fc15.x86_64
NetworkManager-0.8.999-2.git20110509.fc15.x86_64
NetworkManager-glib-0.8.999-2.git20110509.fc15.x86_64
NetworkManager-pptp-0.8.999-1.fc15.x86_64
NetworkManager-openconnect-0.8.999-1.fc15.x86_64
evolution-NetworkManager-3.0.1-1.fc15.x86_64
NetworkManager-vpnc-0.8.999-2.fc15.x86_64
[nme@rtln4ge ~]$
Comment 3 Nik Lam 2011-05-22 03:21:23 EDT
This is /var/log/messages when you connect the n900 via USB:

May 22 00:18:21 rtln4ge kernel: [ 2745.367755] usb 2-1.4: new high speed USB device using ehci_hcd and address 12
May 22 00:18:21 rtln4ge kernel: [ 2745.454489] usb 2-1.4: New USB device found, idVendor=0421, idProduct=01c8
May 22 00:18:21 rtln4ge kernel: [ 2745.454496] usb 2-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
May 22 00:18:21 rtln4ge kernel: [ 2745.454501] usb 2-1.4: Product: N900 (PC-Suite Mode)
May 22 00:18:21 rtln4ge kernel: [ 2745.454504] usb 2-1.4: Manufacturer: Nokia
May 22 00:18:21 rtln4ge kernel: [ 2745.459032] cdc_acm 2-1.4:1.6: This device cannot do calls on its own. It is not a modem.
May 22 00:18:21 rtln4ge kernel: [ 2745.459134] cdc_acm 2-1.4:1.6: ttyACM0: USB ACM device
May 22 00:18:21 rtln4ge kernel: [ 2745.461227] cdc_ether 2-1.4:1.8: usb0: register 'cdc_ether' at usb-0000:00:1d.0-1.4, CDC Ethernet Device, 92:19:45:94:fb:cc
May 22 00:18:21 rtln4ge mtp-probe: checking bus 2, device 12: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4"
May 22 00:18:21 rtln4ge mtp-probe: bus: 2, device: 12 was not an MTP device
May 22 00:18:21 rtln4ge modem-manager[1123]: <info>  (ttyACM0) opening serial port...
May 22 00:18:22 rtln4ge modem-manager[1123]: <info>  (ttyACM0) closing serial port...
May 22 00:18:22 rtln4ge modem-manager[1123]: <info>  (ttyACM0) serial port closed
May 22 00:18:22 rtln4ge modem-manager[1123]: <info>  (ttyACM0) opening serial port...
May 22 00:18:22 rtln4ge modem-manager[1123]: <info>  (Nokia): GSM modem /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.4 claimed port ttyACM0
May 22 00:18:22 rtln4ge modem-manager[1123]: <info>  (ttyACM0) closing serial port...
May 22 00:18:23 rtln4ge modem-manager[1123]: <info>  (ttyACM0) serial port closed
May 22 00:18:23 rtln4ge NetworkManager[4951]: <warn> (ttyACM0): failed to look up interface index
May 22 00:18:23 rtln4ge NetworkManager[4951]: <info> (ttyACM0): new GSM/UMTS device (driver: 'cdc_acm' ifindex: -1)
May 22 00:18:23 rtln4ge NetworkManager[4951]: <info> (ttyACM0): exported as /org/freedesktop/NetworkManager/Devices/2
May 22 00:18:23 rtln4ge NetworkManager[4951]: <info> (ttyACM0): now managed
May 22 00:18:23 rtln4ge NetworkManager[4951]: <info> (ttyACM0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
May 22 00:18:23 rtln4ge NetworkManager[4951]: <info> (ttyACM0): deactivating device (reason: 2).
May 22 00:18:23 rtln4ge NetworkManager[4951]: <info> (ttyACM0): device state change: unavailable -> disconnected (reason 'none') [20 30 0]
Comment 4 Neil Bryant 2011-06-01 20:31:57 EDT
Exactly the same issue; also worked fine in F14. I'm in F15 now, running Gnome Shell. Have not yet got it to work via bluetooth, but I seem to have Gnomes in my Shell as far as that goes.

Can provide logs, but they look just like those already here. Here are my vagueries:

[me@qosmio ~]$ uname -a
Linux qosmio 2.6.38.6-27.fc15.x86_64 #1 SMP Sun May 15 17:23:28 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

[]~ rpm -qa | grep Manager
NetworkManager-vpnc-0.8.999-2.fc15.x86_64
NetworkManager-pptp-0.8.999-1.fc15.x86_64
NetworkManager-gnome-0.8.999-3.git20110526.fc15.x86_64
NetworkManager-glib-0.8.999-3.git20110526.fc15.x86_64
NetworkManager-openconnect-0.8.999-1.fc15.x86_64
NetworkManager-0.8.999-3.git20110526.fc15.x86_64
ModemManager-0.4-8.git20110427.fc15.x86_64
NetworkManager-openvpn-0.8.999-1.fc15.x86_64


I did find the following link that looked similar, and indicated the N900 takes longer than average to connect.
https://bugzilla.redhat.com/show_bug.cgi?id=583691
Comment 5 Henrik Nordström 2011-06-23 08:58:16 EDT
I currently suspect it's a timing issue. It sometimes works once after restarting modemmanager.

What else can be done to collect relevant information to narrow this down?
Comment 6 Dan Williams 2011-07-18 18:55:57 EDT

*** This bug has been marked as a duplicate of bug 583691 ***
Comment 7 Dan Williams 2011-07-18 18:56:17 EDT
This is fixed now with latest MM update; N900 is usable.