Bug 706728

Summary: qemu does not support full kqemu support
Product: [Fedora] Fedora Reporter: Raphael Groner <projects.rg>
Component: qemuAssignee: Justin M. Forbes <jforbes>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: amit.shah, bazanluis20, berrange, dougsland, dwmw2, ehabkost, extras-orphan, gcosta, itamar, jaswinder, jforbes, knoel, ondrejj, scottt.tw, virt-maint
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-11-30 09:45:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Raphael Groner 2011-05-22 10:26:36 EDT
Description of problem:
Enable full support for kqemu.

Version-Release number of selected component (if applicable):
qemu-0.13.0-1.fc14.x86_64
qemu-launcher-1.7.4-7.fc12.noarch
kqemu-1.4.0-0.5.pre1.fc14.noarch
kernel-2.6.35.13-91.fc14.x86_64


How reproducible:
always

Steps to Reproduce:
1. start Qemu Launcher
2. enable Full support for kqemu
3.
  
Actual results:
error (see below)

Expected results:
just works

Additional info:
/usr/bin/qemu -monitor stdio -boot d -m 512 -cdrom  '/home/raphael/Downloads/Fedora/Fusion-Linux-14/Fusion-Linux-14.iso' -net nic,vlan=0 -net user,vlan=0 -localtime -kernel-kqemu &
qemu: -kernel-kqemu: invalid option
Comment 1 Daniel Berrange 2011-05-23 06:04:32 EDT
kqemu support was killed by QEMU upstream developers 2 years ago, and as such is not in Fedora any more:


commit 4a1418e07bdcfaa3177739e04707ecaec75d89e1
Author: Anthony Liguori <aliguori@us.ibm.com>
Date:   Mon Aug 10 17:07:24 2009 -0500

    Unbreak large mem support by removing kqemu
    
    kqemu introduces a number of restrictions on the i386 target.  The worst is that
    it prevents large memory from working in the default build.
    
    Furthermore, kqemu is fundamentally flawed in a number of ways.  It relies on
    the TSC as a time source which will not be reliable on a multiple processor
    system in userspace.  Since most modern processors are multicore, this severely
    limits the utility of kqemu.
    
    kvm is a viable alternative for people looking to accelerate qemu and has the
    benefit of being supported by the upstream Linux kernel.  If someone can
    implement work arounds to remove the restrictions introduced by kqemu, I'm
    happy to avoid and/or revert this patch.
    
    N.B. kqemu will still function in the 0.11 series but this patch removes it from
    the 0.12 series.


Fedora won't be patching QEMU to re-introduce this functionality, unless upstream re-introduces it, which is almost certainly never going to happen.
Comment 2 Raphael Groner 2011-05-23 14:38:33 EDT
Reassigning to [orphaned] qemu-launcher due to it provides an option for "full" support of kqemu.
Comment 3 Raphael Groner 2011-11-30 09:45:12 EST
kqemu has been replaced by KVM.