Bug 706959

Summary: segfault when empty %prep section
Product: [Fedora] Fedora Reporter: Enrico Scholz <rh-bugzilla>
Component: rpmAssignee: Panu Matilainen <pmatilai>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: ffesti, jnovy, pmatilai, ravanhagen
Target Milestone: ---Keywords: Upstream
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: rpm-4.9.0-9.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-15 05:37:39 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Enrico Scholz 2011-05-23 15:28:46 UTC
Description of problem:

When spec file with %build has an empty %prep section, 'rpmbuild -bs' segfaults:

----
Name:           x
Version:        0
Release:        0
Summary:        0
Group:          x
License:        x

%description

%prep
%build

%files
----

$ rpmbuild -bs --target x86_64 --nodeps xx.spec 
Building target platforms: x86_64
Building for target x86_64
Segmentation fault


Version-Release number of selected component (if applicable):

rpm-4.9.0-6.fc15


How reproducible:

100%

Comment 1 Panu Matilainen 2011-05-24 05:49:17 UTC
Yup, this was just recently noticed and fixed upstream. Will be fixed in next update.

Comment 2 Panu Matilainen 2011-05-24 12:21:01 UTC
*** Bug 704765 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2011-06-10 10:35:34 UTC
rpm-4.9.0-9.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/rpm-4.9.0-9.fc15

Comment 4 Fedora Update System 2011-06-11 04:32:52 UTC
Package rpm-4.9.0-9.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rpm-4.9.0-9.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/rpm-4.9.0-9.fc15
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-06-15 05:37:28 UTC
rpm-4.9.0-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.