Bug 707123

Summary: fence-agents rebase
Product: Red Hat Enterprise Linux 6 Reporter: Fabio Massimo Di Nitto <fdinitto>
Component: fence-agentsAssignee: Fabio Massimo Di Nitto <fdinitto>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2CC: cluster-maint, rsteiger, ssaha
Target Milestone: rcKeywords: Rebase
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: Rebase
Fixed In Version: fence-agents-3.1.5-1.el6 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
This update adds a couple of minor features and fixes a few bugs, and will make future updates easier.
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 07:22:49 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Fabio Massimo Di Nitto 2011-05-24 02:59:14 EDT
Initial evaluation shows that we can rebase safely based on a new tarball
released from upstream.

Pros:

1) move to standalone tarball
2) kill patch queue from distcvs
3) simplify build / spec file

Verification process:

(same deal as cluster and rgmanager rebase)
sed -i -e 's#\-b .*##g' fence-agents.spec
make prep

we will use fence-agents from upstream directly here (next release)

Upstream has moved to autotool vs custom build. Skipping Makefile
diff here.

diff -Naurd fence-agents-3.0.12 fence-agents-3.1.4 | filterdiff -i
'*fence/agents*' -x '*Makefile*' |  less

upstream changes:

bladecenter_snmp renamed to ibmblade (compat is retained via symlink
both upstream and in RHEL6)

cisco_ucs: rhbz#691392

dropped drac/test_drac.sh (not shipped anyway)

eaton_snmp/ added upstream, not shipped/unsupported

ibmblade (renamed from bladecenter - see above)

ipmilan - add generated include from autotools
        - fix help text output (no bz, obvious fix)
        - fix monitor return code (Resolves: rhbz#690735)

lib/XenAPI.py.py -> part of fence_xenapi (unsupported/not shipped)

lib/fencing.py.py -> Xen + vmware support.

manual/fence_ack_manual.sh renamed to .sh.in for integration with
autotools build. No other changes.

node_assassin/ new upstream agent (unsupported/not shipped)

nss_wrapper/fence_nss_wrapper.c add generated include from autotools

rackswitch/do_rack.c add generated include from autotools

rhevm/fence_rhevm.py rhbz#691392

rsa: rhbz#652619

scsi: rhbz#673575 (this would be the only feature that would be part of
upstream tarball pre-6.2 development). If this is problematic for QE to
ACK, we can temporary revert the 4 patches upstream, do a release and
re-add them as patches in 6.2 distcvs. Basically, it´s a no-brainer.

vmware_soap new agent rhbz#634567

xenapi new upstream agent (unsupported/not shipped)

xvm -> dead and gone upstream, never shipped in rhel6

TODO: fix upstream build system do support list of agents to ship/install.
Comment 2 Fabio Massimo Di Nitto 2011-05-26 09:27:56 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This update adds a couple of minor features and fixes a few bugs, and will make future updates easier.
Comment 3 Fabio Massimo Di Nitto 2011-06-08 03:22:02 EDT
For QE convenience, attaching rpmdiff output + explanation for small bits.

[fabbione@daikengo RHEL-6]$ rpmdiff -i S /srv/mirrors/rhel/6/Server/x86_64/os/Packages/fence-agents-3.0.12-23.el6.x86_64.rpm fence-agents-3.1.4-1.el6.x86_64.rpm 
added       REQUIRES libdl.so.2()(64bit)  
added       REQUIRES libnssutil3.so()(64bit)  
added       REQUIRES libplc4.so()(64bit)  
added       REQUIRES libplds4.so()(64bit)  
added       REQUIRES libpthread.so.0()(64bit)  
added       REQUIRES libsmime3.so()(64bit) 
added       REQUIRES perl(File::Path)

^^^^ expected due to improved linking from autotools.

removed     PROVIDES fence-agents(x86-64) = 3.0.12-23.el6
added       PROVIDES fence-agents(x86-64) = 3.1.4-1.el6
..........T /usr/sbin/fence_ack_manual
..5.......T /usr/sbin/fence_apc
..5.......T /usr/sbin/fence_apc_snmp
..5.......T /usr/sbin/fence_bladecenter
.M5.......T /usr/sbin/fence_bladecenter_snmp

^^^expected as part of bladecenter_snmp rename to ibmblade and added compat symlink. In rhel6.1 it was done the other way around.

..5.......T /usr/sbin/fence_brocade
..5.......T /usr/sbin/fence_cisco_mds
..5.......T /usr/sbin/fence_cisco_ucs
..5.......T /usr/sbin/fence_drac
..5.......T /usr/sbin/fence_drac5
..5.......T /usr/sbin/fence_egenera
..5.......T /usr/sbin/fence_eps
.M5.......T /usr/sbin/fence_ibmblade

^^^expected as above

..5.......T /usr/sbin/fence_ifmib
..5.......T /usr/sbin/fence_ilo
..5.......T /usr/sbin/fence_ilo_mp
..5.......T /usr/sbin/fence_intelmodular
..5.......T /usr/sbin/fence_ipmilan
..5.......T /usr/sbin/fence_nss_wrapper
..5.......T /usr/sbin/fence_rhevm
..5.......T /usr/sbin/fence_rsa
..5.......T /usr/sbin/fence_rsb
..5.......T /usr/sbin/fence_sanbox2
..5.......T /usr/sbin/fence_scsi
..5.......T /usr/sbin/fence_virsh
..5.......T /usr/sbin/fence_vmware
..5.......T /usr/sbin/fence_vmware_helper
..5.......T /usr/sbin/fence_wti
added       /usr/share/cluster
added       /usr/share/cluster/fence_scsi_check.pl

^^^^ part of #673575

removed     /usr/share/doc/fence-agents-3.0.12
removed     /usr/share/doc/fence-agents-3.0.12/COPYING.applications
removed     /usr/share/doc/fence-agents-3.0.12/COPYING.libraries
removed     /usr/share/doc/fence-agents-3.0.12/COPYRIGHT
removed     /usr/share/doc/fence-agents-3.0.12/README.licence
added       /usr/share/doc/fence-agents-3.1.4
added       /usr/share/doc/fence-agents-3.1.4/COPYING.applications
added       /usr/share/doc/fence-agents-3.1.4/COPYING.libraries
added       /usr/share/doc/fence-agents-3.1.4/COPYRIGHT
added       /usr/share/doc/fence-agents-3.1.4/README.licence
..........T /usr/share/fence
..5.......T /usr/share/fence/fencing.py
..5.......T /usr/share/fence/fencing.pyc
..5.......T /usr/share/fence/fencing.pyo
..5.......T /usr/share/fence/fencing_snmp.py
..5.......T /usr/share/fence/fencing_snmp.pyc
..5.......T /usr/share/fence/fencing_snmp.pyo
..........T /usr/share/man/man8/fence_ack_manual.8.gz
..5.......T /usr/share/man/man8/fence_apc.8.gz
..5.......T /usr/share/man/man8/fence_apc_snmp.8.gz
..5.......T /usr/share/man/man8/fence_bladecenter.8.gz
.M5.......T /usr/share/man/man8/fence_bladecenter_snmp.8.gz

^^^same as above but for man page.

..........T /usr/share/man/man8/fence_brocade.8.gz
..5.......T /usr/share/man/man8/fence_cisco_mds.8.gz
..5.......T /usr/share/man/man8/fence_cisco_ucs.8.gz
..........T /usr/share/man/man8/fence_drac.8.gz
..5.......T /usr/share/man/man8/fence_drac5.8.gz
..........T /usr/share/man/man8/fence_egenera.8.gz
..5.......T /usr/share/man/man8/fence_eps.8.gz
..5.......T /usr/share/man/man8/fence_ibmblade.8.gz
..5.......T /usr/share/man/man8/fence_ifmib.8.gz
..5.......T /usr/share/man/man8/fence_ilo.8.gz
..5.......T /usr/share/man/man8/fence_ilo_mp.8.gz
..5.......T /usr/share/man/man8/fence_intelmodular.8.gz
..........T /usr/share/man/man8/fence_ipmilan.8.gz
..5.......T /usr/share/man/man8/fence_rhevm.8.gz
..5.......T /usr/share/man/man8/fence_rsa.8.gz
..........T /usr/share/man/man8/fence_rsb.8.gz
..5.......T /usr/share/man/man8/fence_sanbox2.8.gz
..........T /usr/share/man/man8/fence_scsi.8.gz
..5.......T /usr/share/man/man8/fence_virsh.8.gz
..5.......T /usr/share/man/man8/fence_vmware.8.gz
..5.......T /usr/share/man/man8/fence_wti.8.gz
Comment 8 Radek Steiger 2011-10-17 10:34:34 EDT
rpmdiff -i S fence-agents-3.0.12-23.el6.i686.rpm fence-agents-3.1.5-1.el6.i686.rpm looks the same as above in Comment #3, the only exception was adding the relaxng files as mentioned in Comment #7.

added       /usr/share/cluster/relaxng
added       /usr/share/cluster/relaxng/fence.rng.head
added       /usr/share/cluster/relaxng/fence.rng.tail
added       /usr/share/cluster/relaxng/fence2man.xsl
added       /usr/share/cluster/relaxng/fence2rng.xsl
Comment 9 Radek Steiger 2011-10-17 10:42:05 EDT
continuing from Comment #8:

added       REQUIRES pyOpenSSL

^^ a resolution of BZ #718207
Comment 10 Radek Steiger 2011-10-17 13:55:01 EDT
Further patches that were tracked down the rebase diff and were not mentioned in Comment #0

fence_apc: rhbz#606297

fence_drac.pl: rhbz#614046 drac, ipmilan, scsi, egenera delay option

fence_eps: rhbz#618703

fence_wti: rhbz#678522

fence_ilo: rhbz#615255
Comment 11 Fabio Massimo Di Nitto 2011-10-17 14:14:41 EDT
(In reply to comment #10)
> Further patches that were tracked down the rebase diff and were not mentioned
> in Comment #0
> 
> fence_apc: rhbz#606297
> 
> fence_drac.pl: rhbz#614046 drac, ipmilan, scsi, egenera delay option
> 
> fence_eps: rhbz#618703
> 
> fence_wti: rhbz#678522
> 
> fence_ilo: rhbz#615255

Yes that is correct. All changes already related/covered by other BZ have not been mentioned in the original diff analysis.
Comment 12 Radek Steiger 2011-10-18 05:41:25 EDT
Rebase from 3.1.4 to 3.1.5 contains:

fence_drac5.py and fencing.py.py: rhbz#718196

fence_bladecenter: rhbz#708052

fence.rng: ship xsl and rng files required to build relaxng schema

fence_ack_manual.in:
http://git.fedorahosted.org/git/?p=fence-agents.git;a=commitdiff;h=08ae2ac78f3e4b216edf4b6689ac235ec9153c6c

********

Modules not shipped/supported are correctly excluded.
Comment 14 errata-xmlrpc 2011-12-06 07:22:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1599.html