Bug 708708

Summary: In LibreOffice comments sticking to GUI, comment boxes malformed
Product: [Fedora] Fedora Reporter: davidshumway
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: caolanm, davidshumway, dtardon, ltinkl
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-16 10:13:26 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Comments sticking to GUI, comment boxes malformed
none
Sample file saved as .doc
none
Malforming UI none

Description davidshumway 2011-05-28 21:03:03 EDT
Created attachment 501552 [details]
Comments sticking to GUI, comment boxes malformed

Hello

There are two errors to take notice of, regarding the way in which the comment boxes are being displayed. These vary according to which layout the document is being viewed in (Print or Web layout).

In Print layout only one error occurs, which is that when scrolling the document the comments begin building up and hanging on the GUI (specifically on the Status Bar and the File Menu). This starts occurring immediately upon starting LibreOffice, in both a brand new empty document as well as a saved document. This is pictured occurring in each of the screen shots. A particular quirk is that by dragging another window above the hanged text, causes the text to clear.

In Web layout when scrolling the document the comments hang on the GUI. Additionally, after after about 15 pages of typing the comment boxes themselves will begin to display poorly. There are probably 5 comments per page in the document, so it starts to occur after probably 75 comments have been made. The boxes leave many horizontal lines on the GUI. The hanging text on the GUI, as with Print layout, disappears when another window is hovered over the location where the error is occurring. However, the horizontal lines do not disappear when hovering a window.


The horizontal lines will start only after a certain comment, and then continue to the end of the page. Scrolling above the comment where the horizontal lines first appeared causes the horizontal lines to disappear. Anywhere below the this comment and the horizontal lines return.

The horizontal lines occur only when in the window is in an unmaximized state, and seem also to be dependent on the size of the unmaximized window. The hanging text on the GUI happens in both states, namely maximized and unmaximized, and regardless of window size.

Interestingly enough, the horizontal lines stop erroring at the start of a new page. Maybe someone knows how long is a page when in Web Layout? So the horizontal lines error below a certain number of comments on page 1 until page 2, then page 2 does not show the error. The set of comments on page 1 (from where the comments start displaying poorly) to the end of page 1 still error.

The files in the screenshots happen to be .doc files, but these errors likewise occur in .odt files and unsaved documents. Copies of a sample file can be provided.

Fedora Release 14

Kernel 2.6.35.13-91.fc14.i686

Hardware: Memory 1.5 GiB, P0 Intel T2060, P1 Intel T2060

Libre Office 3.3.2.2
Comment 1 davidshumway 2011-05-28 21:05:17 EDT
LibreOffice installed System->Administration->Add/Remove Software. OpenOffice previously was installed on the system and was uninstalled after LibreOffice messaged that it was required to remove OpenOffice.
Comment 2 David Tardon 2011-05-30 04:11:35 EDT
Where did you get the rpms? There is no libreoffice in F-14. Anyway, I cannot reproduce it so we would need a sample file.
Comment 3 davidshumway 2011-05-30 11:37:07 EDT
Indeed, this skipped my mind, I downloaded the rpms from libreoffice.org. As this is the case, this may be moved to https://bugs.freedesktop.org/
Comment 4 davidshumway 2011-05-30 11:53:21 EDT
Created attachment 501842 [details]
Sample file saved as .doc
Comment 5 davidshumway 2011-06-07 13:35:53 EDT
No one else is finding errors in my files, so it must be software or hardware related on my end.

Now running Fedora 14 on Gateway MA7 dual core T2050 1.6GHZ. Within 1 month ago was running CentOS 5.5 on the same machine and the same errors were appearing, malformed comment boxes and comment words sticking to the GUI.

Any place to look for software or hardware error messages (logs, etc.)? Maybe drivers needed updating?

I've just recently used b43-fwcutter to install drivers for my wireless card--all other hardware is using out-of-the-box software.
Comment 6 davidshumway 2011-06-09 14:36:47 EDT
Created attachment 503969 [details]
Malforming UI

Additionally the text in the body of document will occasionally hang over the "text boundaries" and even run off the page, apparently hidden behind the comments area, hence becoming unselectable, as well as various other UI glitches such as Paragraph symbols displaying out of place slightly margined to the left.

This will sometimes reset after updating the line on which it is occurring; however, for at least 100 paragraphs in one section of the current document this behaviour is engrained, i.e. the malformed behaviour exists even after re-opening the document.
Comment 7 Caolan McNamara 2011-06-16 10:13:26 EDT
They work fine here with >= 3.3.2.2, and valgrind doesn't notice anything dodgy.

It looks more like a video driver issue rather than an application issue.
Comment 8 davidshumway 2011-07-29 11:42:46 EDT
Formatted drive and installed Fedora 15, now using Gnome 3. So, fresh start! Comments sticking to the GUI no longer persists; however, the comment boxes are still malforming, leaving their horizontal bounding box lines in the comment section.

The graphics driver in settings says it's IntelĀ® 945GM. As probably a driver/Xorg issue, would anyone have time to walk through checking video driver settings on my side? Or can someone recommend a place to begin reading on the video driver?