This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 709954

Summary: Korean input broken after switching from 2bul to 3bul Yetgeul and back
Product: Red Hat Enterprise Linux 5 Reporter: Kenichi Takemura <ktakemur>
Component: scim-hangulAssignee: Jens Petersen <petersen>
Status: CLOSED DEFERRED QA Contact: QE Internationalization Bugs <qe-i18n-bugs>
Severity: medium Docs Contact:
Priority: low    
Version: 5.7CC: ebaak, eng-i18n-bugs, lijli
Target Milestone: ---Keywords: i18n, Rebase
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
: 767112 (view as bug list) Environment:
Last Closed: 2011-09-13 00:54:08 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 767112    
Attachments:
Description Flags
Render issue none

Description Kenichi Takemura 2011-06-02 01:32:54 EDT
Description of problem:

I type a Korean word '백과사전' using the key sequences 'qorrhktkwjs「Enter」' in gedit.
Once I change 'Input Layout' of Hangul scim task bar on the bottom left in Desktop '두벌식' -> '세벌식 옛글' -> '두벌식'(Back to default), Gedit cannot render '백과사전' any more when typing the sane key sequence.
It renders 4-digits characters(unicode) instead. 

Version-Release number of selected component (if applicable):
scim-bridge-gtk-0.4.5-9.el5
scim-1.4.4-44.el5
scim-qtimm-0.9.4-5
scim-bridge-gtk-0.4.5-9.el5
scim-libs-1.4.4-44.el5
scim-libs-1.4.4-44.el5
scim-hangul-0.2.2-7.fc6
scim-qtimm-0.9.4-5
scim-bridge-0.4.5-9.el5
[root@unused-12-196 ~]# rpm -qa | grep gedit
gedit-2.16.0-9.el5


How reproducible:
100%

Steps to Reproduce:
1. Start korean desktop
2. Open gedit and trun scim Korean on
3. Type 'qorrhktkwjs「Enter」'
4. Change 'Input Layout' '두벌식' -> '세벌식 옛글' -> '두벌식'
5. Type 'qorrhktkwjs「Enter」'
  
Actual results:
Gedit cannot render '백과사전' in step5

Expected results:
Gedit can render '백과사전'

Additional info:
Comment 1 Kenichi Takemura 2011-06-02 01:33:23 EDT
Created attachment 502425 [details]
Render issue
Comment 2 Jens Petersen 2011-06-09 04:33:09 EDT
Reproduced - I assume this is not a regression?
Comment 3 Jens Petersen 2011-06-09 04:45:52 EDT
Doesn't happen with scim in F15.
Comment 4 Jens Petersen 2011-06-09 04:48:16 EDT
This could probably be fixed by update scim-hangul to a newer version
but it is probably a bit late in the RHEL5 lifecycle for that.
Comment 6 Jens Petersen 2011-08-30 02:16:33 EDT
I think "3bul Yetgeul" is a pretty little used layout
and given there are a lot of changes from latest scim-hangul,
and that this is not a customer bug I would like to propose to
defer this bug.
Comment 7 Jens Petersen 2011-09-13 00:54:08 EDT
This doesn't look like it will make 5.8 so closing deferred.
Comment 8 Jens Petersen 2011-12-16 01:50:39 EST
*** Bug 767112 has been marked as a duplicate of this bug. ***