Bug 710202

Summary: package updater error: Missing Dependency: libibumad.so.2
Product: Red Hat Enterprise Linux 5 Reporter: kamo.g.s
Component: yumAssignee: packaging-team-maint
Status: CLOSED WONTFIX QA Contact: Red Hat Satellite QA List <satellite-qa-list>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 5.6CC: james.antill
Target Milestone: rcKeywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-11 16:30:44 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description kamo.g.s 2011-06-02 12:37:25 EDT
Description of problem:

================================================================================
 Package         Arch       Version            Repository                  Size
================================================================================
Installing:
 libibumad       i386       1.3.3-1.el5        rhel-x86_64-server-5        55 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 55 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libibumad.so.3 is needed by (installed) libibmad-1.3.6-1.i686
libibumad.so.3 is needed by (installed) opensm-libs-3.3.7_MLNX-1.i686
libibumad.so.3 is needed by (installed) libibumad-devel-1.3.6-1.i686
libibumad.so.3(IBUMAD_1.0) is needed by (installed) libibmad-1.3.6-1.i686
libibumad.so.3(IBUMAD_1.0) is needed by (installed) opensm-libs-3.3.7_MLNX-1.i686
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
Comment 1 James Antill 2011-06-02 13:02:03 EDT
What does the following say:

rpm -Va --nofiles --nodigest
Comment 2 kamo.g.s 2011-06-02 13:22:30 EDT
rpm -Va --nofiles --nodigest
Unsatisfied dependencies for mpitests_mvapich_intel-3.2-923.x86_64: libimf.so()(64bit)
Unsatisfied dependencies for mpitests_openmpi_intel-3.2-923.x86_64: libimf.so()(64bit)
Comment 3 James Antill 2011-06-03 10:34:12 EDT
Ok, if you solve the pre-existing rpmdb problems yum should not get confused anymore.
Comment 4 kamo.g.s 2011-06-03 14:12:09 EDT
Installed package rpm -i intel-icc9-libs-9.0-025.x86_64.rpm
rpm -Va --nofiles --nodigest returns back blank.
Still getting problem:
================================================================================
 Package         Arch       Version            Repository                  Size
================================================================================
Installing:
 libibumad       i386       1.3.3-1.el5        rhel-x86_64-server-5        55 k

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total size: 55 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libibumad.so.3 is needed by (installed) libibmad-1.3.6-1.i686
libibumad.so.3 is needed by (installed) opensm-libs-3.3.7_MLNX-1.i686
libibumad.so.3 is needed by (installed) libibumad-devel-1.3.6-1.i686
libibumad.so.3(IBUMAD_1.0) is needed by (installed) libibmad-1.3.6-1.i686
libibumad.so.3(IBUMAD_1.0) is needed by (installed) opensm-libs-3.3.7_MLNX-1.i686
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])
Comment 5 James Antill 2011-06-03 15:21:17 EDT
What does:

yum list libibumad

...say?

 I think I see what the problem is, you have:

libibmad-1.3.6-1.i686 (installed)
libibmad-1.3.3-1.el5.i386 (available)

...and yum/rpm are getting confused about the arch change, and the downgrade. If you really want to downgrade, you might be able to do:

yum shell
remove  libibmad
install libibmad.i386
run

...or just fix the repos. you are using so that it's not as confusing.
Comment 6 kamo.g.s 2011-06-03 15:30:36 EDT
What I really want is install latest packages from RedHat.

Here is an original problem:
 yum update srptools
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package srptools.x86_64 0:0.0.4-8.el5 set to be updated
--> Processing Dependency: libibumad.so.2(IBUMAD_1.0)(64bit) for package: srptools
--> Processing Dependency: libibumad.so.2()(64bit) for package: srptools
--> Finished Dependency Resolution
srptools-0.0.4-8.el5.x86_64 from rhel-x86_64-server-5 has depsolving problems
  --> Missing Dependency: libibumad.so.2(IBUMAD_1.0)(64bit) is needed by package srptools-0.0.4-8.el5.x86_64 (rhel-x86_64-server-5)
srptools-0.0.4-8.el5.x86_64 from rhel-x86_64-server-5 has depsolving problems
  --> Missing Dependency: libibumad.so.2()(64bit) is needed by package srptools-0.0.4-8.el5.x86_64 (rhel-x86_64-server-5)
Error: Missing Dependency: libibumad.so.2(IBUMAD_1.0)(64bit) is needed by package srptools-0.0.4-8.el5.x86_64 (rhel-x86_64-server-5)
Error: Missing Dependency: libibumad.so.2()(64bit) is needed by package srptools-0.0.4-8.el5.x86_64 (rhel-x86_64-server-5)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
Comment 7 James Antill 2011-06-03 16:30:36 EDT
What you really want then is distro-sync, but that isn't in the RHEL-5 yum.

You could just do a 2 stage "reinstall", where you run:

yum remove libibumad

...and then install it from the RHEL repo.
Comment 8 James Antill 2013-03-11 16:30:44 EDT
Back porting distro-sync isn't going to happen, sorry. You can use RHEL-6 or the unofficial yum backport from RHEL-6 (check my private repos. on fedoraproject).

This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.

However, Red Hat will further review this request for potential 
inclusion in future major releases of Red Hat Enterprise Linux.