Bug 710639

Summary: Review Request: gnome-shell-extension-remove-volume-icon - A gnome-shell extension for removing the volume icon
Product: [Fedora] Fedora Reporter: Fabian Affolter <mail>
Component: Package ReviewAssignee: Tim Lauridsen <tla>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: fedora-package-review, gwync, notting, tla
Target Milestone: ---Flags: tla: fedora-review+
gwync: fedora-cvs+
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: gnome-shell-extension-remove-volume-icon-0.1-1.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-15 18:39:10 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Fabian Affolter 2011-06-03 21:30:17 UTC
Spec URL: http://fab.fedorapeople.org/packages/SRPMS/gnome-shell-extension-remove-volume-icon.spec
SRPM URL: http://fab.fedorapeople.org/packages/SRPMS/gnome-shell-extension-remove-volume-icon-0.1-1.fc15.src.rpm

Project URL: http://www.affolter-engineering.ch/index.php?page=remove-volume-icon

Description:
This Gnome shell extension removes the volume icon from the panel.

Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=3110576

rpmlint output:
[fab@laptop021 SRPMS]$ rpmlint gnome-shell-extension-remove-volume-icon*
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

[fab@laptop021 noarch]$ rpmlint gnome-shell-extension-remove-volume-icon*
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

Comment 1 Tim Lauridsen 2011-06-05 06:45:48 UTC
I will review this package

Comment 2 Tim Lauridsen 2011-06-05 06:50:19 UTC
Package Review
==============

Key:
- = N/A
x = Check
! = Problem
? = Not evaluated

[x] : MUST - Package successfully compiles and builds into binary rpms on at least one supported architecture.
[x] : MUST - Spec file lacks Packager, Vendor, PreReq tags.
[x] : MUST - Package does not contain any libtool archives (.la)
[x] : MUST - Package use %makeinstall only when make install DESTDIR=... doesn't work.
[x] : MUST - Package is named according to the Package Naming Guidelines.
[x] : MUST - Rpmlint output is silent.
        
        rpmlint gnome-shell-extension-remove-volume-icon-0.1-1.fc16.noarch.rpm
        ================================================================================
        1 packages and 0 specfiles checked; 0 errors, 0 warnings.
        ================================================================================
        
        rpmlint gnome-shell-extension-remove-volume-icon-0.1-1.fc16.src.rpm
        ================================================================================
        1 packages and 0 specfiles checked; 0 errors, 0 warnings.
        ================================================================================
        
[x] : MUST - Sources used to build the package matches the upstream source, as provided in the spec URL.
        MD5SUM this package     : 4db257409a6d9cf194911235b0b5cb59
        MD5SUM upstream package : 4db257409a6d9cf194911235b0b5cb59
[x] : MUST - Spec file name must match the spec package %{name}, in the format %{name}.spec.
[-] : MUST - %config files are marked noreplace or the reason is justified.
[-] : MUST - Package contains a properly installed %{name}.desktop using desktop-file-install file if it is a GUI application.
[-] : MUST - Fully versioned dependency in subpackages, if present.
[-] : MUST - Header files in -devel subpackage, if present.
[-] : MUST - ldconfig called in %post and %postun if required.
[-] : MUST - License file installed when any subpackage combination is installed.
[-] : MUST - The spec file handles locales properly.
[-] : MUST - No %config files under /usr.
[-] : MUST - Development .so files in -devel subpackage, if present.
[-] : MUST - Static libraries in -static subpackage, if present.
[x] : MUST - Package is licensed with an open-source compatible license and meets other legal requirements as defined in the legal section of Packaging Guidelines.
[-] : MUST - %build honors applicable compiler flags or justifies otherwise.
[x] : MUST - All build dependencies are listed in BuildRequires, except for any that are listed in the exceptions section of Packaging Guidelines.
[x] : MUST - Package contains no bundled libraries.
[x] : MUST - Changelog in prescribed format.
[x] : MUST - Sources contain only permissible code or content.
[x] : MUST - Macros in Summary, %description expandable at SRPM build time.
[x] : MUST - Package requires other packages for directories it uses.
[x] : MUST - Package uses nothing in %doc for runtime.
[x] : MUST - Package is not known to require ExcludeArch.
[x] : MUST - Permissions on files are set properly.
[x] : MUST - Package does not contain duplicates in %files.
[-] : MUST - Large documentation files are in a -doc subpackage, if required.
[x] : MUST - If (and only if) the source package includes the text of the license(s) in its own file, then that file, containing the text of the license(s) for the package is included in %doc.
[x] : MUST - License field in the package spec file matches the actual license.
[x] : MUST - Package consistently uses macros. instead of hard-coded directory names.
[x] : MUST - Package meets the Packaging Guidelines.
[x] : MUST - Package does not generates any conflict.
[x] : MUST - Package does not contains kernel modules.
[x] : MUST - Package contains no static executables.
[x] : MUST - Package obeys FHS, except libexecdir and /usr/target.
[x] : MUST - Package must own all directories that it creates.
[x] : MUST - Package does not own files or directories owned by other packages.
[x] : MUST - Package installs properly.
[x] : MUST - Rpath absent or only used for internal libs.
[x] : MUST - Package is not relocatable.
[x] : MUST - Requires correct, justified where necessary.
[x] : MUST - Spec file is legible and written in American English.
[-] : MUST - Package contains a SysV-style init script if in need of one.
[x] : MUST - File names are valid UTF-8.
[-] : MUST - Useful -debuginfo package or justification otherwise.
[x] : SHOULD - Reviewer should test that the package builds in mock.
[x] : SHOULD - Dist tag is present.
[x] : SHOULD - SourceX / PatchY prefixed with %{name}.
[x] : SHOULD - SourceX is a working URL.
[x] : SHOULD - Spec use %global instead of %define.
[-] : SHOULD - Uses parallel make.
[-] : SHOULD - The placement of pkgconfig(.pc) files are correct.
[x] : SHOULD - If the source package does not include license text(s) as a separate file from upstream, the packager SHOULD query upstream to include it.
[x] : SHOULD - No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x] : SHOULD - Final provides and requires are sane (rpm -q --provides and rpm -q --requires).
[x] : SHOULD - Package functions as described.
[x] : SHOULD - Latest version is packaged.
[x] : SHOULD - Package does not include license text files separate from upstream.
[x] : SHOULD - Man pages included for all executables.
[-] : SHOULD - Patches link to upstream bugs/comments/lists or are otherwise justified.
[x] : SHOULD - Scriptlets must be sane, if used.
[!] : SHOULD - Description and summary sections in the package spec file contains translations for supported Non-English languages, if available.
[x] : SHOULD - Package should compile and build into binary rpms on all supported architectures.
[-] : SHOULD - %check is present and all tests pass.
[x] : SHOULD - Packages should try to preserve timestamps of original installed files.

Issues:

None

APPROVED

Comment 3 Fabian Affolter 2011-06-05 10:19:54 UTC
New Package VCS Request
=======================
Package Name: gnome-shell-extension-remove-volume-icon 
Short Description: A gnome-shell extension for removing the volume icon
Owners: fab
Branches: F15
InitialCC:

Comment 4 Gwyn Ciesla 2011-06-05 22:46:19 UTC
New Package SCM Request
=======================
Package Name: gnome-shell-extension-remove-volume-icon 
Short Description: A gnome-shell extension for removing the volume icon
Owners: fab
Branches: f15
InitialCC:

Comment 5 Gwyn Ciesla 2011-06-05 22:46:45 UTC
Git done (by process-git-requests).

Comment 6 Fedora Update System 2011-06-06 18:06:35 UTC
gnome-shell-extension-remove-volume-icon-0.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-shell-extension-remove-volume-icon-0.1-1.fc15

Comment 7 Fedora Update System 2011-06-07 04:44:05 UTC
gnome-shell-extension-remove-volume-icon-0.1-1.fc15 has been pushed to the Fedora 15 testing repository.

Comment 8 Fedora Update System 2011-06-15 18:39:05 UTC
gnome-shell-extension-remove-volume-icon-0.1-1.fc15 has been pushed to the Fedora 15 stable repository.