Bug 7114

Summary: xfs prevents fifth X server from starting
Product: [Retired] Red Hat Linux Reporter: James Manning <jmm>
Component: XFree86Assignee: Preston Brown <pbrown>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-02-03 21:53:06 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description James Manning 1999-11-18 19:55:20 UTC
Stock RH 6.1, XF86_SVGA server, gdm, as root (just to make sure it
wasn't perms)

from a text screen, startx -- :{1,2,3} all work fine, starting up
an X server on vt's {8,9,10} respectively.  doing the startx -- :4
to start a fifth server, the screen blanks like it's starting X, then
it dies and kicks back to the text vt, with the messages:

failed to set default font path 'unix/:-1'
Fatal server error:
could not open default font 'fixed'

Out of curiosity, I stop'd and start'd xfs and then :4 worked fine
(this will probably break fonts on :{0,1,2,3} though :)

I can't find anything in the xfs docs about a limitation to four
X servers, so I'm unsure of how to fix this.

This is on a user's machine (board designer) and he claims that the
capability to start 6 X sessions worked fine in RH 6.0 and only after
the 6.1 reinstall (fresh install, no upgrade) did it fail.

Comment 1 Alexandre Blanchette 2000-01-13 02:19:59 UTC
in /etc/X11/fs/config, change the line client-limit = 4 with the number of X
Sessions you want to have simultneously.

Comment 2 Preston Brown 2000-02-03 21:53:59 UTC
or change clone-self=off to clone-self=on.  This will be the new default in 6.2.