This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 711422

Summary: Broken dependency on deprecated hal-info
Product: [Fedora] Fedora Reporter: Nicola Soranzo <nsoranzo>
Component: libmtpAssignee: Linus Walleij <triad>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: triad
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libmtp-1.0.6-3.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-07 17:53:35 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Nicola Soranzo 2011-06-07 09:18:01 EDT
Description of problem:
Since HAL has been deprecated upstream for 3 years, all major distributions are removing it. You can find more details on the accepted Fedora Feature page:

https://fedoraproject.org/wiki/Features/HalRemoval

The hal-info package has already been deprecated by its maintainer and blocked from composes for rawhide.
Therefore, the following broken dependency for your package should be removed:

libmtp-hal-1.0.6-2.fc16.i686 requires hal-info

Since no other package depends on libmtp-hal, I would suggest to completely remove the libmtp-hal subpackage for rawhide.

Version-Release number of selected component (if applicable):

libmtp-1.0.6-2.fc16
Comment 1 Linus Walleij 2011-06-07 17:35:03 EDT
OK I've kicked a build where libmtp-hal isn't in it...
Comment 2 Nicola Soranzo 2011-06-07 17:53:35 EDT
Thanks Linus, I'm closing the bug report then!