Bug 712950

Summary: show package name for missing build_ids
Product: [Fedora] Fedora Reporter: Jonathan <emailjonathananderson-fedora>
Component: abrtAssignee: Martin Milata <mmilata>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: high    
Version: 15CC: anton, dvlasenk, iprikryl, jmoskovc, kklic, mmilata, mtoman, npajkovs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: abrt-2.0.10-1.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-18 23:00:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 744774    
Attachments:
Description Flags
eu-unstrip -n --core coredump none

Description Jonathan 2011-06-13 17:49:00 UTC
Description of problem:
abrt fails to generate a backtrace because of missing debuginfo.
The error message needs to be more specific so I can take care of the problem.

Version-Release number of selected component (if applicable):
2.0.2-5.fc15

How reproducible:
always

Steps to Reproduce:
1.try to generate a backtrace
2.
3.
  
Actual results:
abrt fails to generate a backtrace with the message:
Coredump references 133 debuginfo files, 1 of them are not installed
Looking for needed packages in repositories
Can't find packages for 1 debuginfo files
Missing debuginfo file: /usr/lib/debug/.build-id/-/.debug
Backtrace is generated and saved, 54915 bytes

/usr/lib exists but not /usr/lib/debug

Expected results:
abrt could tell me which package this missing debuginfo file is related to, and more things I could use to remedy the problem. The message now leaves me in the dark about how to fix the problem.

Additional info:

Comment 1 Jiri Moskovcak 2011-06-13 18:20:24 UTC
the line: 

> Missing debuginfo file: /usr/lib/debug/.build-id/-/.debug

seems like there was involved a binary without build_id - which means that it didn't come from Fedora official package. Or it can be a bug in ABRT. Would you mind uploading the core (please note, that the coredump contains the memory of the crashed process, so it can contain some sensitive data you don't want to share...)

Comment 2 Jonathan 2011-06-13 18:53:19 UTC
No problem, I'll upload it if I can.

Are you referring to the "coredump" file? It is 200 Mb and bugzilla will only let me upload 20 Mb. Can I extract the data you need to make it smaller?

Comment 3 Jiri Moskovcak 2011-06-13 19:09:32 UTC
Yes, that's the file, uploading the output of:

$ eu-unstrip -n --core coredump 

should give us some clues.

Comment 4 Jonathan 2011-06-13 20:14:43 UTC
Created attachment 504537 [details]
eu-unstrip -n --core coredump

Comment 5 Nikola Pajkovsky 2011-06-14 08:43:02 UTC
Problematic lines are:

0x344f200000+0x30c000 - /usr/lib64/nvidia/libGL.so.1 - libGL.so.1
0x3449000000+0x202000 - /usr/lib64/nvidia/tls/libnvidia-tls.so.270.41.06 - libnvidia-tls.so.270.41.06
0x344d000000+0x1c4d000 - /usr/lib64/nvidia/libnvidia-glcore.so.270.41.06 - libnvidia-glcore.so.270.41.06

You are using binary blob from Nvidia and we can do nothing for you :-/

Comment 6 Jonathan 2011-06-14 09:25:09 UTC
Ok, I understand that, but could abrt at least say that?
That would save a lot of troubleshooting time for users.

Like if it could say "We cannot analyze this as you are using Nvidias proprietary driver"?

Comment 7 Jonathan 2011-06-14 09:26:17 UTC
Does this also mean that no crash can ever be reported in this way until nouveau reaches maturity?

Comment 8 Jiri Moskovcak 2011-06-14 14:25:51 UTC
(In reply to comment #7)
> Does this also mean that no crash can ever be reported in this way until
> nouveau reaches maturity?

- if only one debuginfo is missing then there is a chance that the backtrace will be usable, the problem is if the crash is somewhere in the nvidia library - that's nothing we (Fedora) can fix.

Comment 9 Jiri Moskovcak 2011-10-10 13:35:27 UTC
I think we can improve the message to say:


Missing debuginfo:

1406558950ff100eb0320a325b3ea7961ba1a775 <package-name>

Comment 10 Martin Milata 2012-03-13 15:14:45 UTC
Should be fixed in git 87a55b3f93d61a789f5538cb5e0937e80ea78398.

The tool now does not attempt to download debuginfo for build ids '-' and instead reports the executable without the build id.

Comment 11 Fedora Update System 2012-03-27 10:18:34 UTC
abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17

Comment 12 Fedora Update System 2012-03-28 05:59:24 UTC
Package abrt-2.0.9-1.fc17, libreport-2.0.10-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.9-1.fc17 libreport-2.0.10-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4804/abrt-2.0.9-1.fc17,libreport-2.0.10-1.fc17
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2012-04-02 13:34:35 UTC
abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/abrt-2.0.10-1.fc17,libreport-2.0.10-2.fc17

Comment 14 Fedora Update System 2012-04-18 23:00:28 UTC
abrt-2.0.10-1.fc17, libreport-2.0.10-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.