Bug 714715

Summary: Legacy SysV initscript file must go into an optional subpackage.
Product: [Fedora] Fedora Reporter: Jóhann B. Guðmundsson <johannbg>
Component: iputilsAssignee: Jiri Skala <jskala>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: aglotov, jskala
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-20 11:04:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713562    

Description Jóhann B. Guðmundsson 2011-06-20 09:50:57 EDT
Description of problem:

Currently your component is providing both native systemd service files and
legacy sysv init script in the same package which is in violation of the
packaging guidelines[1]. 

Once a native systemd service file is shipped and if the intention is to
continue to maintain and ship the old sysv initscript the old sysvinit must go
into an optional subpackage.

"SysV Initscripts
Packages may also provide a SysV initscript file, but are not required to do
so. This format is considered legacy, but Fedora still contains init mechanisms
such as upstart which do not support the systemd unit file format. If present,
the SysV initscript(s) must go into an optional subpackage, so as not to
confuse sysadmins. The guidelines for SysV initscripts can be found here:
Packaging:SysVInitScript"

1.http://fedoraproject.org/wiki/Packaging:Guidelines:Systemd

Version-Release number of selected component (if applicable):

iputils-20101006-8.fc16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jiri Skala 2011-06-20 11:04:20 EDT

*** This bug has been marked as a duplicate of bug 697532 ***