Bug 714810

Summary: Incorrect XML in Legal Notice?
Product: [Fedora] Fedora Reporter: Nathan Thomas <nathan>
Component: publican-fedoraAssignee: Ruediger Landmann <r.landmann>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: ari.jolma, mmcallis, r.landmann
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: publican-fedora-2.0-3.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-23 23:46:27 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File with corrected xml for copyright year and holder none

Description Nathan Thomas 2011-06-20 16:47:05 EDT
Created attachment 505694 [details]
File with corrected xml for copyright year and holder

Description of problem:
When I build the Live Image Guide with publican-fedora, the copyright year and holder are shown incorrectly - &YEAR; &HOLDER; is displayed instead of the actual year and holder.

The copyright information is drawn with the rest of the legal notice from /usr/share/publican/Common_Content/fedora/<lang>/Legal_Notice.xml.

I think the error is due to incorrect xml on line 6 of Legal_Notice.xml - it reads '&amp;YEAR; &amp;HOLDER;'. Changing it to '&YEAR; &HOLDER;' causes the information to be displayed correctly.


Version-Release number of selected component (if applicable):
publican-fedora-2.0-0.fc15

How reproducible:
Build a document with 'publican build' and the publican-fedora branding.

  
Actual results:
The first line of the legal notice in the built document will read 'Copyright &YEAR; &HOLDER;.'

Expected results:
The line should read 'Copyright 2011, Red Hat & others.'


Additional info:
I've attached a Legal_Notices.xml file with what I think is the correct xml.
Comment 1 Ruediger Landmann 2011-06-21 23:18:16 EDT
(In reply to comment #0)

> Description of problem:
> When I build the Live Image Guide with publican-fedora, the copyright year and
> holder are shown incorrectly - &YEAR; &HOLDER; is displayed instead of the
> actual year and holder.

Thanks Nathan; the XML was correct in the source but somehow got expanded during build on Koji.

I've just rebuilt the package and the entities are correct in 2.0-3.
Comment 2 Fedora Update System 2011-06-21 23:21:35 EDT
publican-fedora-2.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/publican-fedora-2.0-3.fc15
Comment 3 Nathan Thomas 2011-06-22 06:05:59 EDT
That's great, the update fixes the problem for me. Thanks Rudi!
Comment 4 Fedora Update System 2011-06-23 23:46:22 EDT
publican-fedora-2.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Ari Jolma 2012-01-18 05:09:25 EST
I'm using publican 2.3-2 on Ubuntu 11.04 (what Ubuntu software center gives me) and hit this problem. But I had to dig deeper to find out why the above did not fix the problem completely. I notice XmlClean using _xml_escape of HTML::Element in my_as_XML. On my system _xml_escape replaces & with &amp; always (or at least in this case - NoExpand does not matter at that low level). Thus the Legal_Notice, which is first copied ok from /usr/share to tmp in doc directory gets broken again in the processing.