This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 715147

Summary: activate module help message shows garbage characters.
Product: Red Hat Enterprise Linux 5 Reporter: Kenichi Takemura <ktakemur>
Component: subscription-managerAssignee: Chris Duryee <cduryee>
Status: CLOSED ERRATA QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.7CC: awood, bkearney, ebaak, fsharath, qe-i18n-bugs
Target Milestone: rcKeywords: i18n
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-07 22:47:31 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 771748    

Description Kenichi Takemura 2011-06-21 21:53:40 EDT
Description of problem:

When hitting 'subscription-manager activate -help', the message about '--locale' options is broken.

$ . /etc/sysconfig/i18n 
$ echo $LANG
zh_TW.UTF-8
$ sudo subscription-manager activate -help
使用方法:subscription-manager activate [OPTIONS]

activate

options:
  -h, --help            顯示此協助訊息並退出
  --debug=DEBUG         除錯層級
  --proxy=PROXY_URL     代理伺服器 url 的格式會是
                        proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        含有基本驗證的 http 代理伺服器的使用者
  --proxypassword=PROXY_PASSWORD
                        含有基本驗證的 http 代理伺服器的密碼
  --email=EMAIL         選用性電子郵件地址,以在 token
                        啟用程序完成時進行通知。
  --locale=LOCALE       當 token 啟用程序完成時,所使用來作為
                        �子郵件通知的選用性語言。僅與 --email
                        搭配使用。範例:en-us、de-de


Version-Release number of selected component (if applicable):
subscription-manager-0.95.5.20-1.el5
subscription-manager-firstboot-0.95.5.20-1.el5
subscription-manager-gnome-0.95.5.20-1.el5


How reproducible:
100%

Steps to Reproduce:
1. 'sudo subscription-manager activate -help' in zh_TW locale
2.
3.
  
Actual results:
Message is garbled.

Expected results:
Message is properly displayed.

Additional info:

Looks po contains good translations.

#: ../src/subscription_manager/managercli.py:497
msgid ""
"optional language to use for email notification when token activation is "
"complete. Used with --email only. Examples: en-us, de-de"
msgstr ""
"當 token 啟用程序完成時,所使用來作為電子郵件通知的選用性語言。僅與 --email "
"搭配使用。範例:en-us、de-de"
Comment 1 Bryan Kearney 2012-02-22 14:18:14 EST
This is now the redeem command. The current code has this bug fixed.
Comment 2 Sharath Dwaral 2012-06-21 14:58:39 EDT
Version 

RHEL 5.9

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-1.0.4-1.git.1.b28337e.el5
subscription-manager-migration-data-1.11.1.1-1.git.2.c7fbafe.el5
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.1.b28337e.el5
subscription-manager-1.0.4-1.git.1.b28337e.el5
subscription-manager-gui-1.0.4-1.git.1.b28337e.el5

--activate is changed to --redeem

# LANG=zh_TW.UTF8 subscription-manager redeem --help
使用用法:subscription-manager redeem [OPTIONS]

試圖為預先配置的電腦取得訂閱服務

options:
  -h, --help            顯示此協助訊息並退出
  --serverurl=SERVER_URL
                        server url in the form of https://hostname:443/prefix
  --baseurl=BASE_URL    base url for content in form of
                        https://hostname:443/prefix
  --proxy=PROXY_URL     代理伺服器 url 的格式會是
                        proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        含有基本驗證的 http 代理伺服器的使用者
  --proxypassword=PROXY_PASSWORD
                        含有基本驗證的 http 代理伺服器的密碼
  --email=EMAIL         取得訂閱服務後,要發送提示的電子郵件位址。
  --locale=LOCALE       取得訂閱服務後,要發送提示的電子郵件之選用語言。例如
                        en-us(美式英文)、de-de(德文)

Note : Only verifying for unreadable characters, not for translations.

Moving bug to verified state
Comment 3 RHEL Product and Program Management 2012-06-21 15:07:29 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 errata-xmlrpc 2013-01-07 22:47:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html