Bug 715152

Summary: 'About LibreOffice' legal notice says "created by Red Hat, Inc."
Product: [Fedora] Fedora Reporter: Richard Fontana <rfontana>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: caolanm, dtardon, ltinkl, rtiller
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-22 04:57:19 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Richard Fontana 2011-06-21 23:09:43 EDT
In LibreOffice-writer, and I assume the other parts of the suite, the 'About' popup window produced via the 'Help' menu list says:

Copyright © 2000, 2010 LibreOffice contributors and/or their affiliates. All rights reserved.
This product was created by Red Hat, Inc., based on OpenOffice.org, which is Copyright 2000, 2010 Oracle and/or its affiliates.
Red Hat, Inc. acknowledges all community members [...]

While strictly speaking the Fedora builds of LibreOffice happen to be created (exclusively?) by Red Hat employees, this seems an inappropriate notice for the Fedora versions of LibreOffice, as Fedora is a community distribution sponsored by, yet not a commercial product of, Red Hat. 

The culprit here seems to be the OOOVENDOR parameter which is set to "Red Hat, Inc.". For Fedora, it would seem more sensible for the value to be "The Fedora Project". 

(There is a larger issue here that I consider an upstream bug: the wording of the legal notice seems to be a partial archaism of the Sun/OpenOffice.org era and now reads rather confusingly for LibreOffice. The notion that builds are things made by "vendors" in particular seems peculiar.)
Comment 1 Caolan McNamara 2011-06-22 04:57:19 EDT
In the past, if you don't set it you got "username", so on an immediate level it had to be something or other to avoid being "koji@build.machine". Previously there was an OOo upstream desire for downstream builds that made any modifications to disambiguate their builds from "official" vanilla builds. 

For the moment I'll disambiguate for rhel vs fedora vs neither builds, and poke upstream what the current thinking is about this now.