Bug 715760

Summary: FTBFS TurboGears-1.1.2-3.fc15
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: TurboGearsAssignee: Luke Macken <lmacken>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: a.badger, fschwarz, lmacken, tremble
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-07-05 18:39:23 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713919    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2011-06-23 11:02:07 EDT
TurboGears-1.1.2-3.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:02:12 EDT
Created attachment 506979 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:02:14 EDT
Created attachment 506980 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:02:15 EDT
Created attachment 506981 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:02:17 EDT
Created attachment 506982 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:02:19 EDT
Created attachment 506983 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:02:21 EDT
Created attachment 506984 [details]
mock.log


mock.log for x86_64
Comment 7 Luke Macken 2011-06-23 14:21:08 EDT
I'm not quite sure what is going on here... at a first glance it looks like it's incompatible with the version of SQLAlchemy that is installed (0.7.1), yet the whole test suite is passing with SA-0.7.1 in our Jenkins instance (http://jenkins.turbogears.org/view/TurboGears%20Hosted/job/TurboGears-1.1-py2.6/89/console). Could be a Python 2.7 vs 2.6 issue?

Needs further investigation.
Comment 8 Toshio Ernie Kuratomi 2011-06-27 21:21:18 EDT
I get similar errors if I run F14 or F15's %check using python setup.py test rather than nosetest -q.  Which is even more confusing because the upstream Jenkins instance is using python setup.py test.

F15's TG package rebuilds so it's not specific to TG1.1 + python-2.7.  We'll have to look more into whether SQLAlchemy-0.7.1 is playing into this somehow.
Comment 9 Toshio Ernie Kuratomi 2011-07-05 18:39:23 EDT
Fixed.  Two issues were present.  SQLAlchemy-0.7.1 needed a pair of patches that I picked up from upstream.  Python-2.7.2 needed a patch to the unittests that I've upstreamed:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3181843

Judging from the recent failures I see on jenkins.turbogears.org, we may have more problems if we decide to upgrade python-sqlobject to 1.0.x as well.