Bug 715777

Summary: FTBFS python-pylons-1.0-2.fc15
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: python-pylonsAssignee: Kyle VanderBeek <kylev>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: dmalcolm, kylev
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: python-pylons-1.0-4.fc17 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 10:57:55 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713919    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2011-06-23 11:06:41 EDT
python-pylons-1.0-2.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:06:45 EDT
Created attachment 507082 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:06:47 EDT
Created attachment 507083 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:06:49 EDT
Created attachment 507084 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:06:50 EDT
Created attachment 507085 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:06:51 EDT
Created attachment 507086 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:06:53 EDT
Created attachment 507087 [details]
mock.log


mock.log for x86_64
Comment 7 Dave Malcolm 2011-11-28 16:16:59 EST
(In reply to comment #5)
> Created attachment 507086 [details]
> build.log
FWIW, this failure was fixed upstream in this commit:

https://github.com/Pylons/pylons/commit/0789e367113f75c41170ba2fbf8250a0390e633f#tests/test_units/test_basic_app.py

I suspect it was due to this change in python-webob:
https://github.com/Pylons/webob/commit/c73cd681b7bb97914f873ace39f70bd59df2289c
Comment 8 Dave Malcolm 2011-12-06 10:53:54 EST
I took the liberty of fixing this in "master" for f17, backporting the patch in comment 7.

Scratch built successfully as:
  http://koji.fedoraproject.org/koji/taskinfo?taskID=3570070

Pushed to master as:
http://pkgs.fedoraproject.org/gitweb/?p=python-pylons.git;a=commit;h=45e4af0b775bb15cdf8cefa2348f501f825fec2c

Building python-pylons-1.0-4.fc17 for dist-rawhide
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=3570210
Comment 9 Dave Malcolm 2011-12-06 10:57:55 EST
The build of python-pylons-1.0-4.fc17 was successful: closing this out.