Bug 715795

Summary: FTBFS perl-Class-DBI-AsForm-2.42-11.fc14
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: perl-Class-DBI-AsFormAssignee: Tom "spot" Callaway <tcallawa>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: perl-devel, ppisar, tcallawa
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-06-28 15:57:05 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 713919    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log
none
Fix none

Description FTBFS 2011-06-23 11:10:34 EDT
perl-Class-DBI-AsForm-2.42-11.fc14.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 11:10:38 EDT
Created attachment 507179 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 11:10:39 EDT
Created attachment 507180 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 11:10:40 EDT
Created attachment 507181 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 11:10:42 EDT
Created attachment 507182 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 11:10:43 EDT
Created attachment 507183 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 11:10:45 EDT
Created attachment 507184 [details]
mock.log


mock.log for x86_64
Comment 7 Petr Pisar 2011-06-24 04:50:42 EDT
F15 affected too.

Two tests fail on trailing white spaces:

#   Failed test 'Select OK'
#   at t/01.t line 43.
#          got: '<select name="bar"><option value="1">Hi</option></select>'
#     expected: '<select name="bar"><option value="1">Hi</option></select>
# '

#   Failed test 'All correct as an object method'
#   at t/01.t line 54.
#     Structures begin differing at:
#          $got->{bar} = '<select name="bar"><option selected value="1">Hi</option></select>'
#     $expected->{bar} = '<select name="bar"><option selected value="1">Hi</option></select>
#     '
# Looks like you failed 2 tests of 4.
t/01.t ............ 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/4 subtests

Seems like incompatible change in perl-HTML-Tree. Last successful build was against 1:perl-HTML-Tree-3.23-10.fc13.noarch.
Comment 8 Petr Pisar 2011-06-24 06:06:56 EDT
HTML-Tree-4.0 removes erroneous trailing new lines. So this tests in this package should be aligned.
Comment 9 Petr Pisar 2011-06-24 06:21:31 EDT
Created attachment 509727 [details]
Fix

Changes submitted to upstream.
Comment 10 Tom "spot" Callaway 2011-06-28 15:57:05 EDT
Fix applied to rawhide (2.42-14), thanks!