Bug 716146

Summary: FTBFS freetennis-0.4.8-18.fc12
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: freetennisAssignee: Hans de Goede <hdegoede>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: bruno, hdegoede, rjones
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: freetennis-0.4.8-21.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-21 14:49:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 785727    
Bug Blocks: 713919    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log none

Description FTBFS 2011-06-23 12:24:22 EDT
freetennis-0.4.8-18.fc12.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:24:25 EDT
Created attachment 509156 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:24:27 EDT
Created attachment 509157 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:24:28 EDT
Created attachment 509158 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:24:30 EDT
Created attachment 509159 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:24:31 EDT
Created attachment 509160 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:24:33 EDT
Created attachment 509161 [details]
mock.log


mock.log for x86_64
Comment 7 Bruno Wolff III 2011-07-15 21:53:25 EDT
freetennis needs ocaml-camlimages which was dropped after F14. Because it was statically linked (normal for ocaml stuff) the package functions in later releases, but can't be rebuilt.

Because ocaml-camlimages has been blocked, it will need a new review to be brought back. And note that it had trouble build during F13 and was never built for F14. Version 4.0.1 is available now and that might help.
Comment 8 Bruno Wolff III 2012-02-04 14:44:27 EST
I have been able to rebuild freetennis using a test build of a new ocaml-calimages package that is currently waiting for review. Once this package is back in Fedora freetennis should build again.
Comment 10 Bruno Wolff III 2012-03-10 12:29:46 EST
ocaml-calimages has been approved. Currently I am waiting for an scm admin to set up the repos again. Once that happens I'll get builds done ASAP and then freetennis rebuilds.
Comment 11 Fedora Update System 2012-03-13 17:47:40 EDT
freetennis-0.4.8-21.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/freetennis-0.4.8-21.fc16
Comment 12 Fedora Update System 2012-03-13 17:48:07 EDT
freetennis-0.4.8-21.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/freetennis-0.4.8-21.fc17
Comment 13 Fedora Update System 2012-03-13 17:48:25 EDT
freetennis-0.4.8-21.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/freetennis-0.4.8-21.fc15
Comment 14 Fedora Update System 2012-03-15 22:43:07 EDT
Package freetennis-0.4.8-21.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing freetennis-0.4.8-21.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3850/freetennis-0.4.8-21.fc17
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2012-03-21 14:49:20 EDT
freetennis-0.4.8-21.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2012-03-26 00:00:51 EDT
freetennis-0.4.8-21.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2012-03-26 00:01:35 EDT
freetennis-0.4.8-21.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2012-03-26 13:52:14 EDT
freetennis-0.4.8-21.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2012-03-26 13:55:00 EDT
freetennis-0.4.8-21.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.