This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 716174

Summary: FTBFS perl-OpenFrame-3.05-13.fc15
Product: [Fedora] Fedora Reporter: FTBFS <ftbfs>
Component: perl-OpenFrameAssignee: Steven Pritchard <steve>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: high    
Version: rawhideCC: notting, perl-devel, ppisar, steve
Target Milestone: ---Keywords: Triaged
Target Release: ---   
Hardware: All   
OS: Linux   
URL: http://linux.dell.com/files/fedora/FixBuildRequires/mock-results/
Whiteboard:
Fixed In Version: perl-OpenFrame-3.05-16.fc16 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-07-06 16:07:14 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 713919    
Attachments:
Description Flags
root.log
none
build.log
none
mock.log
none
root.log
none
build.log
none
mock.log
none
fix none

Description FTBFS 2011-06-23 12:29:54 EDT
perl-OpenFrame-3.05-13.fc15.src.rpm Failed To Build From Source against the rawhide tree.  See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug.  Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug.  If the other package does not yet have a bug created that you think matches, please create one.  Doing so helps us properly track bugs and their dependencies, just as we track package dependencies.  (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created.  Please follow the above advice to avoid such duplication.)
Comment 1 FTBFS 2011-06-23 12:29:57 EDT
Created attachment 509321 [details]
root.log


root.log for i386
Comment 2 FTBFS 2011-06-23 12:29:59 EDT
Created attachment 509322 [details]
build.log


build.log for i386
Comment 3 FTBFS 2011-06-23 12:30:00 EDT
Created attachment 509323 [details]
mock.log


mock.log for i386
Comment 4 FTBFS 2011-06-23 12:30:01 EDT
Created attachment 509324 [details]
root.log


root.log for x86_64
Comment 5 FTBFS 2011-06-23 12:30:03 EDT
Created attachment 509325 [details]
build.log


build.log for x86_64
Comment 6 FTBFS 2011-06-23 12:30:04 EDT
Created attachment 509326 [details]
mock.log


mock.log for x86_64
Comment 7 Petr Pisar 2011-06-24 08:36:17 EDT
Tests fail:

Can't call method "name" on an undefined value at /builddir/build/BUILD/OpenFrame-3.05/blib/lib/OpenFrame/Cookies.pm line 47.
# Looks like you planned 15 tests but ran 2.
# Looks like your test exited with 255 just after 2.
t/01request.t ....... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 13/15 subtests 
no_plan takes no arguments at t/02http_request.t line 10.
[OpenFrame::Segment::HTTP::Response::OpenFrame::Segment::HTTP::Response::dispatch] no response available at /usr/share/perl5/vendor_perl/Pipeline/Dispatch.pm line 74
t/02http_request.t .. ok
t/03argument.t ...... ok
Can't call method "name" on an undefined value at /builddir/build/BUILD/OpenFrame-3.05/blib/lib/OpenFrame/Cookies.pm line 47.
# Looks like you planned 20 tests but ran 2.
# Looks like your test exited with 255 just after 2.
t/04response.t ...... 
Dubious, test returned 255 (wstat 65280, 0xff00)
Failed 18/20 subtests 

This happens when tests do:

  ok($cookie = OpenFrame::Cookies->new(), "created cookietin okay");
  ok($cookie->set(colour => "red"), "set cookie okay");

Because $cookie->set() does:

  my $cookie = OpenFrame::Cookie->new();
  $cookie->name( $key );

and that fails because OpenFrame::Cookie->new() returns undef,

OpenFrame::Cookie is ISA of CGI::Cookie and CGI::Cookie->new() returns undef.

Seems like bug in CGI::Cookie, that is provided with perl-CGI.

Last successful build was against 0:perl-CGI-3.50-2.fc15.noarch.
Comment 8 Petr Pisar 2011-06-24 08:42:02 EDT
Fist incompatatible CGI::Cookie version is perl-CGI-3.51-1.fc15.noarch.
Comment 9 Petr Pisar 2011-06-24 08:59:15 EDT
It's a feature according to CGI-3.51 changelog:

Version 3.51, Jan 5, 2011
  [BUG FIXES]
  - CGI::Cookie->new() now follows the documentation and returns undef 
    if the -name and -value args aren't provided. This new behavior is also
    consistent with the docs and code of CGI::Simple::Cookie. (Mark Stosberg)

Thus this is bug in OpenFrame when constructing CGI::Cookie (parented) objects.
Comment 10 Petr Pisar 2011-06-24 09:30:35 EDT
Created attachment 509759 [details]
fix
Comment 11 Petr Pisar 2011-06-24 09:39:57 EDT
As we have CGI 3.51 in all Fedoras, this bug affects all Fedoras.
Comment 12 Marcela Mašláňová 2011-06-24 09:55:15 EDT
Applied in git.