Bug 716330

Summary: rm multiple files needs -f in test-update-copyright.sh
Product: [Fedora] Fedora Reporter: JW <ohtmvyyn>
Component: grepAssignee: Jaroslav Škarvada <jskarvad>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: rawhideCC: jskarvad, lkundrak
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-07-11 06:14:12 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Proposed fix none

Description JW 2011-06-23 22:09:20 EDT
Description of problem:
In the file gnulib-tests/test-update-copyright.sh there are a number of invocations of "rm" on multiple files without a "-f" option.

Version-Release number of selected component (if applicable):
grep-2.7-5

How reproducible:
Always

Steps to Reproduce:
1. grep 'rm ' gnulib-tests/*.sh | grep -v '[-]r*f'
2.
3.
  
Actual results:
1. gnulib-tests/test-update-copyright.sh:rm $TMP*

Expected results:
1.

Additional info:
Please patch the script to use 'rm -f $TMP*'.

If you looks everywhere else (in grep.spec, in Makefiles, in tests/*.sh) you will see that the right thing is always done. They use 'rm -f' so that there is zero likelihood that 'rm' will try prompting to remove a file (because of permissions, or because a variant of 'rm', which prompts by default when confronted with multiple files, is installed).
Comment 1 Jaroslav Škarvada 2011-07-11 05:52:26 EDT
Created attachment 512163 [details]
Proposed fix
Comment 2 Jaroslav Škarvada 2011-07-11 06:04:23 EDT
I recognize this to be a very minor problem, thus I am moving it to rawhide.

Justification: Currently it doesn't cause any problem in build system and most users do not rebuild the package, thus it is probably not worth to let the fix go through critical path update process.

I will also report this to upstream.

If you need the F15 fix, please comment here, otherwise I will backport it to F15 in case of another bugfix update.
Comment 3 Jaroslav Škarvada 2011-07-11 06:14:12 EDT
Upstream ticket:
http://savannah.gnu.org/bugs/index.php?33747