Bug 722736

Summary: mirrormanager fails to display welcome page after login
Product: [Fedora] Fedora EPEL Reporter: Jonathan Martens <jonathan>
Component: mirrormanagerAssignee: Matt Domsch <matt_domsch>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: el6CC: a.badger, jonstanley, matt_domsch
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2015-07-23 04:06:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jonathan Martens 2011-07-17 08:29:13 UTC
Description of problem:

When running mirrormanager with the prod.cfg file from the RPM I get a traceback after logging in, the webpage I requested is not served instead a 500 error is generated.

Version-Release number of selected component (if applicable):

mirrormanager-1.3.7-1.el6.noarch
TurboGears-1.1.2-2.el6.noarch
python-2.6.5-3.el6.i686

How reproducible:
100%

Steps to Reproduce:
1. Execute the dummy installation steps as described here https://fedorahosted.org/mirrormanager/wiki/MirrorManagerInstallation
2. Access the webpage at http://server/mirrormanager
3. Login as Admin user
  
Actual results:

A 500 exception is thrown to the browser. The log files show a file is not there (which seems a file generated from a kid template):

[Sun Jul 17 10:30:01 2011] [error] 2011-07-17 10:30:01,737 turbogears.identity.soprovider INFO Bad _csrf_token
[Sun Jul 17 10:30:01 2011] [error] 2011-07-17 10:30:01,737 turbogears.identity.soprovider INFO No _csrf_token present
[Sun Jul 17 10:30:01 2011] [error] 2011-07-17 10:30:01,772 turbogears.identity.soprovider INFO Bad _csrf_token
[Sun Jul 17 10:30:01 2011] [error] 2011-07-17 10:30:01,772 turbogears.identity.soprovider INFO No _csrf_token present
[Sun Jul 17 10:30:02 2011] [error] 10.0.10.249 - - [17/Jul/2011:08:30:02 +0000] "GET /mirrormanager/ HTTP/1.1" 403 4083 "" "Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0"
[Sun Jul 17 10:30:03 2011] [error] 2011-07-17 10:30:03,793 cherrypy.msg INFO HTTP: Page handler: <bound method Root.index of <mirrormanager.controllers.Root object at 0xb47c1f0c>>
[Sun Jul 17 10:30:03 2011] [error] Traceback (most recent call last):
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 121, in _run
[Sun Jul 17 10:30:03 2011] [error]     self.main()
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/CherryPy-2.3.0-py2.6.egg/cherrypy/_cphttptools.py", line 264, in main
[Sun Jul 17 10:30:03 2011] [error]     body = page_handler(*virtual_path, **self.params)
[Sun Jul 17 10:30:03 2011] [error]   File "<string>", line 3, in index
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 361, in expose
[Sun Jul 17 10:30:03 2011] [error]     *args, **kw)
[Sun Jul 17 10:30:03 2011] [error]   File "<generated code>", line 0, in run_with_transaction
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/peak/rules/core.py", line 153, in __call__
[Sun Jul 17 10:30:03 2011] [error]     return self.body(*args, **kw)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/database.py", line 410, in so_rwt
[Sun Jul 17 10:30:03 2011] [error]     retval = func(*args, **kw)
[Sun Jul 17 10:30:03 2011] [error]   File "<generated code>", line 0, in _expose
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/peak/rules/core.py", line 153, in __call__
[Sun Jul 17 10:30:03 2011] [error]     return self.body(*args, **kw)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 390, in <lambda>
[Sun Jul 17 10:30:03 2011] [error]     fragment, options, args, kw)))
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 451, in _execute_func
[Sun Jul 17 10:30:03 2011] [error]     fragment, **options)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/controllers.py", line 100, in _process_output
[Sun Jul 17 10:30:03 2011] [error]     headers=headers, fragment=fragment, **options)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/view/base.py", line 203, in render
[Sun Jul 17 10:30:03 2011] [error]     return engine.render(**kw)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/turbogears/view/genshisupport.py", line 31, in render
[Sun Jul 17 10:30:03 2011] [error]     return self.transform(info, template).render(**kwargs)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/genshi/template/plugin.py", line 155, in transform
[Sun Jul 17 10:30:03 2011] [error]     return super(MarkupTemplateEnginePlugin, self).transform(data, template)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/genshi/template/plugin.py", line 115, in transform
[Sun Jul 17 10:30:03 2011] [error]     template = self.load_template(template)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/genshi/template/plugin.py", line 97, in load_template
[Sun Jul 17 10:30:03 2011] [error]     return self.loader.load(templatename)
[Sun Jul 17 10:30:03 2011] [error]   File "/usr/lib/python2.6/site-packages/genshi/template/loader.py", line 237, in load
[Sun Jul 17 10:30:03 2011] [error]     raise TemplateNotFound(filename, search_path)
[Sun Jul 17 10:30:03 2011] [error] TemplateNotFound: Template "/usr/share/mirrormanager/server/mirrormanager/templates/welcome.html" not found
[Sun Jul 17 10:30:03 2011] [error]
[Sun Jul 17 10:30:03 2011] [error] 10.0.10.249 - admin [17/Jul/2011:08:30:03 +0000] "POST /mirrormanager/?_csrf_token=2c84ccd230a7f18bc8f8d9de38e69c75c672f2a9 HTTP/1.1" 500 791 "http://c6.snetram.nl/mirrormanager/" "Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0"

Expected results:

A html page with the welcome page after a succesfull login and a welcome.html page located at 

/usr/share/mirrormanager/server/mirrormanager/templates/welcome.html

Comment 1 Matt Domsch 2011-11-14 04:35:47 UTC
That should be looking for a Kid template, not a Genshi template...

Comment 2 Jonathan Martens 2011-11-14 17:22:25 UTC
(In reply to comment #1)
> That should be looking for a Kid template, not a Genshi template...

Matt, do you have any pointers on how to tackle or troubleshoot this further?

Comment 3 Toshio Ernie Kuratomi 2011-11-14 20:11:59 UTC
/me looking to see if we have this issue on fedora-infrastructure's rhel6 test instance.

Comment 4 Toshio Ernie Kuratomi 2011-11-14 20:24:48 UTC
Looks like we have some hotfixes applied to make this work on RHEL6.  I see that I committed the fixes to my local tree but forgot to push them :-(  I've done so now.

http://git.fedorahosted.org/git/?p=mirrormanager;a=commitdiff;h=b65e1e2b28b6534e2b90e2d35e7f7da4f75c6dbb

This is the particular piece of that changeset that should fix the error you're seeing:

index a09f610..e6f68bc 100644 (file)
--- a/server/mirrormanager/config/app.cfg
+++ b/server/mirrormanager/config/app.cfg
@@ -10,14 +10,14 @@
 
 # which view (template engine) to use if one is not specified in the
 # template name
-# tg.defaultview = "kid"
+tg.defaultview = "kid"

Since I fixed this a while ago, I'm not 100% certain if the other changes to app.cfg are also necessary or I just felt being explicit would future-proof those defaults.

The change to the config file (in the rpm it would be installed as /etc/mirrormanager/prod.cfg) was necessary in our setup but it may not be in yours.  I don't recall whether my analysis of the bug indicated that it would affect everyone or just us (since we use the jsonfas identity plugin to authenticate against the Fedora Account System).

Comment 5 Matt Domsch 2011-11-18 01:32:18 UTC
Thanks Toshio.  Patch applied upstream.  Next build will have it.