Bug 723054

Summary: libgcc_post_upgrade.c does not compile on ARM and causes building the package to fail
Product: [Fedora] Fedora Reporter: Niels de Vos <ndevos>
Component: gccAssignee: Jakub Jelinek <jakub>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: rawhideCC: aravindvijayan224185, jakub, pbrobinson
Target Milestone: ---Keywords: Patch, Reopened
Target Release: ---   
Hardware: arm7   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-28 04:11:15 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 245418    
Attachments:
Description Flags
How libgcc_post_upgrade was replaced with a lua scriptlet in rawhide none

Description Niels de Vos 2011-07-18 16:54:00 EDT
Created attachment 513683 [details]
How libgcc_post_upgrade was replaced with a lua scriptlet in rawhide

Description of problem:
When building gcc on ARM, libgcc_post_upgrade.c gives errors on compiling (well, actually linking).

Version-Release number of selected component (if applicable):
gcc-4.5.1-5.f14

How reproducible:
100%

Steps to Reproduce:
1. fedpkg clone gcc
2. cd gcc
3. fedpkg switch-branch f14
4. arm-koji build --scratch dist-f14 $(fedpkg giturl)
(note that building gcc on ARM takes *long*)

Actual results:
Build fails with error like
+ gcc -static -Os /builddir/build/SOURCES/libgcc_post_upgrade.c -o /builddir/build/BUILDROOT/gcc-4.5.1-5.fc14.arm/usr/sbin/libgcc_post_upgrade
/usr/lib/gcc/armv5tel-redhat-linux-gnueabi/4.5.1/../../../libc.a(libc-start.o): In function `__libc_start_main':
(.text+0x0): multiple definition of `__libc_start_main'
/tmp/cct9sTeV.o:libgcc_post_upgrade.c:(.text+0x84): first defined here
/usr/lib/gcc/armv5tel-redhat-linux-gnueabi/4.5.1/../../../libc.a(elf-init.o): In function `__libc_csu_init':
(.text+0x4): multiple definition of `__libc_csu_init'
/tmp/cct9sTeV.o:libgcc_post_upgrade.c:(.text+0x74): first defined here
/usr/lib/gcc/armv5tel-redhat-linux-gnueabi/4.5.1/../../../libc.a(elf-init.o): In function `__libc_csu_fini':
(.text+0x9c): multiple definition of `__libc_csu_fini'
/tmp/cct9sTeV.o:libgcc_post_upgrade.c:(.text+0x78): first defined here
collect2: ld returned 1 exit status


Expected results:
Build succeeds.

Additional info:
gcc in rawhide does not use libgcc_post_upgrade anymore, this binary has been replaced by a lua scriptlet (Bug 705832). A patch with that change is attached for reference. It is probably preferred to replace the libgcc_post_upgrade binary by the lua script, and not add extra patches or update libgcc_post_upgrade.c.
Comment 1 Aravind vijayan 2011-12-27 23:56:05 EST
    Thank you for your bug report. 

    We are sorry, but the Fedora Project is no longer releasing bug fixes or any other updates for this version of Fedora. This bug will be set to CLOSED:WONTFIX to reflect this, but please reopen it if the problem persists after upgrading to the latest version of Fedora, which is available from: 

    http://fedoraproject.org/get-fedora 



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Jakub Jelinek 2011-12-28 04:11:15 EST
libgcc_post_upgrade doesn't exist on rawhide (nor f16 nor f15), so can you explain why you are reopening it?
Comment 3 Peter Robinson 2011-12-28 04:27:10 EST
(In reply to comment #2)
> libgcc_post_upgrade doesn't exist on rawhide (nor f16 nor f15), so can you
> explain why you are reopening it?

Because that wasn't explained in the bug report.