This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 723337

Summary: A "skeleton" group in addition to "default" group
Product: Red Hat Enterprise MRG Reporter: Erik Erlandson <eerlands>
Component: wallabyAssignee: Will Benton <willb>
Status: CLOSED ERRATA QA Contact: Lubos Trilety <ltrilety>
Severity: low Docs Contact:
Priority: low    
Version: 2.0CC: eerlands, iboverma, ltrilety, matt, mkudlej, tmckay, tstclair, willb
Target Milestone: 2.1Keywords: TechPreview
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: wallaby-0.11.0-4 Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-23 12:27:35 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 743350    

Description Erik Erlandson 2011-07-19 15:41:55 EDT
Default group only applies to a node if there is no other configuration.  Skeleton group always applies.  Or, vice versa, for backward compatible semantics of default.
Comment 6 Martin Kudlej 2011-09-29 07:10:55 EDT
How we can test this bug? Is there any repro scenario?
Comment 7 Will Benton 2011-10-14 23:41:59 EDT
To test this feature, run wallaby-agent with the --enable-skeleton-group option or with WALLABY_ENABLE_SKELETON_GROUP=true in your environment.  When it is enabled, this feature adds newly-created nodes to a group called +++SKEL.  Features and parameter settings applied to +++SKEL will thus be applied to all nodes in +++SKEL, but --- unlike the default group --- nodes can be removed from +++SKEL.
Comment 9 Lubos Trilety 2011-10-26 11:38:00 EDT
Tested on:
wallaby-0.12.1-1
condor-wallaby-tools-4.1.1-1

ccs/p doesn't list skeleton group
# ccp --list-all-groups
Groups:
  group1
  group2
  Internal Default Group
# wallaby list-groups
Console Connection Established...
the default group +++DEFAULT
the skeleton group +++SKEL
group1
group2

Another question is if there shouldn't be a new option for the skeleton group in ccp similar to the one for default group.

>>> ASSIGNED
Comment 14 Lubos Trilety 2011-10-27 10:57:00 EDT
Tested with:
wallaby-0.12.1-1

Tested on:
RHEL6 i386, x86_64
RHEL5 i386, x86_64

As it is a tech preview support of the skeleton group in wallaby tools ccs/p will be added later for that a new Bug 749569 was created.

In wallaby skeleton group works fine, when enabled any new node was automatically added to skeleton group (+++SKEL). It is possible to remove a node from such group later.

>>> VERIFIED
Comment 16 errata-xmlrpc 2012-01-23 12:27:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0045.html