Bug 7253

Summary: PCMCIA networking refuses to switch to another LAN
Product: [Retired] Red Hat Linux Reporter: peter
Component: kernelAssignee: Jeff Garzik <jgarzik>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: peterm
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-01-25 03:16:28 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description peter 1999-11-23 13:00:03 UTC
We have a laptop with a Xircom network card, running RH 6.

It works fine on its home LAN.  When switching it to a new location,
Windows 98 is fine (the hardware is OK), but Linux won't talk on the new

Having changed
ifconfig and route report the correct values.

Attempting to ping on the network causes no activity on eth0; however,
the RX/TX count on the loopback device increases sporadically (ie it only
increases when attempting to ping, but not unless the ping has been trying
for a moderate number of packets).

Also worth noting was that when I ran

ifconfig eth0 up

a route for the LAN would be automatically added; however, if I tried to
delete this route, I'd get a "SIOCDELRT: no such process" error (the same
as trying to delete a route that did not exist).  This behaviour could just
be a Redhat-ism (I normally use Debian, and it certainly doesn't add
undeleteable routes...)

I just put the machine back on the original network and Redhat is working
fine again....

Comment 1 Craig B. Markwardt 1999-12-01 01:55:59 UTC
The report above mentions modifying the /etc/pcmcia/network.opts file.

It seems that the RedHat version of the PCMCIA tools do not include the
"network" script from the standard PCMCIA package.  This certainly causes
all network.opts configurations to fail (they are ignored).

If the reason for this is to coexist with the control-panel application, then
couldn't that goal be achieved far less intrusively via a default scheme in
network.opts using the start_fn() and stop_fn() settings?

Comment 2 Cristian Gafton 2000-01-04 22:26:59 UTC
Assigned to dledford

Comment 3 Peter J. Braam 2000-01-16 21:33:59 UTC
When configuring PCMCIA networking through netcfg the config options end up in
/etc/sysconfig/networking-scripts, not in /etc/pcmcia/network.opts.  Is that


Comment 4 Jeff Garzik 2002-10-11 19:37:55 UTC
(updating an ancient bug)

Can you try to reproduce on a current Red Hat or kernel.org kernel?

Comment 5 Stephen John Smoogen 2003-01-25 03:16:28 UTC
I am unable to duplicate this bug on an Inspiron 8000 with Xircon card running
Red Hat Linux 7.3/8.0

I am feeling that this bug has been fixed by time.