Bug 727520

Summary: Can't install or remove ibus-table-xingma
Product: [Fedora] Fedora Reporter: Mike Ma <zhtx10>
Component: ibus-table-xingmaAssignee: Ding-Yi Chen <dchen>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: aalam, dchen, i18n-bugs
Target Milestone: ---Keywords: i18n, Triaged
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-06 05:49:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Ma 2011-08-02 11:20:00 UTC
Description of problem:
Can't install or remove ibus-table-xingma.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. sudo yum install ibus-table-xingma
2. sudo yum remove ibus-table-xingma #not installed
3. sudo yum install ibus-table-xingma #installed
  
Actual results:
I can add ZhengMa to my ibus.

Expected results:
Can't find it and can't reinstall, remove or install.

Additional info:

Comment 1 Mike Ma 2011-08-02 11:25:37 UTC
sorry I'm wrong.

Here are the real informations,
first I install it. didn't find anything. try to reinstall it.
1. sudo yum install ibus-table-xingma #didn't return anything
2. sudo yum remove ibus-table-xingma #not installed
3. sudo yum reinstall ibus-table-xingma #not installed.

Hope can fix it soon.

Comment 2 Ding-Yi Chen 2011-09-06 05:49:02 UTC
Hi Mike,

ibus-table-xingma is obsoleted by ibus-table-chinese, so it is no longer in repository.

In terms of ZhengMa, ibus-table-chinese does not include ZhengMa, because ZhengMa is not freely distributable, and ZhongYi (who possesses the copyright of ZhengMa) has filed lawsuit against Microsoft for not paying licence fee for Windows later than Windows 95.

If you do need ZhengMa, you can manually install ibus-table-xingma by:
1) Download ibus-table-xingma from http://s390.koji.fedoraproject.org/koji/buildinfo?buildID=57191
2) Install it with sudo rpm -ivh ibus-table-xingma-1.2.0.20100305-3.fc15.noarch.rpm
3) Set version lock so yum update won't obsolete it, see Q4 in http://yum.baseurl.org/wiki/Faq
have detail explanation.

Regards,