Bug 7277

Summary: Misc errors in /etc/rc.d/init.d/xinetd
Product: [Retired] Red Hat Powertools Reporter: Andri Bjdrby <penguin>
Component: 9wmAssignee: Bernhard Rosenkraenzer <bero>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.1   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2000-01-19 18:11:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Andri Bjdrby 1999-11-24 10:26:23 UTC
1. The restart|reload and sreload arguments uses "killproc -USRx
xinetd",should be "killproc xinetd -USRx". I believe this kind of bug has
already been reported for samba. Next time, do a "grep 'killproc -'
/etc/rc.d/init.d/*".

2. The start argument uses "daemon xinetd -pid 2> /var/run/xinetd.pid", but
since daemon() uses initlog this makes constructs of the '2>' kind
worthless. Xinetds pid now ends up in /var/log/messages instead.

Comment 1 Bernhard Rosenkraenzer 2000-01-19 18:11:59 UTC
Thanks, fixed.