Bug 727716

Summary: An error occurred during conversion seam text to html
Product: [Retired] Zanata Reporter: Manuel Ospina <mospina>
Component: Component-UIAssignee: zanata-dev-internal <zanata-dev-internal>
Status: CLOSED CURRENTRELEASE QA Contact: Ding-Yi Chen <dchen>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 1.3CC: aeng, camunoz, sflaniga, yshao, zanata-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-23 04:33:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 756229    

Description Manuel Ospina 2011-08-03 01:51:54 UTC
Description of problem:
When trying to edit a project, I go this error
An error occurred during conversion seam text to html

Version-Release number of selected component (if applicable): Zanata version 1.3 (20110509-2113). 


How reproducible:
Always


Steps to Reproduce:
1. Go to https://translate.engineering.redhat.com//project/view/rhn_subscription_management&cid=22550
2. Click edit
3. 
  
Actual results:
Go to an error page

Expected results:
It should go to the project edit page


Additional info:

Comment 1 Sean Flanigan 2011-08-03 07:37:39 UTC
Thanks for the report Manuel. This is caused by a bug in Seam's richfaces library, which doesn't handle (eg) unmatched underscores in SeamText fields (which we use in our Project pages).  So if the content uses an odd number of underscores, it breaks the SeamText editor.

We'll have to go into the database and remove the offending text, as a workaround.

Zanata 1.4 will have an updated richfaces library which fixes the problem properly.

Comment 2 Sean Flanigan 2011-08-05 06:14:38 UTC
We've updated the offending database entries to remove the underscores as a temporary workaround.

NB: if you want to include a URL which uses underscore, you could try using the three characters "%5F" instead of underscore.

Comment 5 Carlos Munoz 2011-11-16 01:37:45 UTC
Added an admin-only section to edit the home page content in plain text, bypassing the rich text editor which is causing the error.

Currently merged to the 1.5.x branch.

Comment 6 Carlos Munoz 2011-11-22 23:47:01 UTC
Merged this upgrade into the 1.4.x branch.

Comment 7 Ding-Yi Chen 2011-11-29 03:23:39 UTC
VERIFIED with Zanata version 1.4.3-alpha-3-SNAPSHOT (20111128-1320)