Bug 727952

Summary: [abrt] kernel: BUG: sleeping function called from invalid context at kernel/mutex.c:85
Product: [Fedora] Fedora Reporter: Matt <matt>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: atomic777, bernardobarros2, bigant, fredoche, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, mail, petr.zika, rtmetz92, tfonteyn, vaarnan, victor.munteanu
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:9ef5e571b32e4691bd4038071518c36e1033f40b
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-06 12:59:15 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Matt 2011-08-03 14:53:11 EDT
abrt version: 2.0.3
architecture:   x86_64
cmdline:        ro root=/dev/mapper/vg00-lv00_root rd_LVM_LV=vg00/lv00_root rd_LVM_LV=vg00/lv01_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=uk rhgb quiet
component:      kernel
kernel:         2.6.40-4.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        kernel
reason:         BUG: sleeping function called from invalid context at kernel/mutex.c:85
time:           Wed Aug  3 19:48:22 2011

backtrace:
:BUG: sleeping function called from invalid context at kernel/mutex.c:85
:in_atomic(): 0, irqs_disabled(): 1, pid: 2249, name: pm-suspend
:Pid: 2249, comm: pm-suspend Not tainted 2.6.40-4.fc15.x86_64 #1
:Call Trace:
: [<ffffffff810474ed>] __might_sleep+0xeb/0xf0
: [<ffffffff814b6366>] mutex_lock+0x24/0x4a
: [<ffffffff814b6ffa>] ? _raw_spin_lock_irqsave+0x12/0x2f
: [<ffffffff810ad9ab>] irq_reserve_irqs+0x3a/0x85
: [<ffffffff810afcea>] irq_set_chip+0x58/0x62
: [<ffffffff810b0072>] ? handle_fasteoi_irq+0x9b/0x9b
: [<ffffffff810b01a2>] irq_set_chip_and_handler_name+0x1e/0x37
: [<ffffffff81023dd5>] arch_setup_hpet_msi+0xc0/0xce
: [<ffffffff81027a15>] hpet_setup_msi_irq+0x19/0x31
: [<ffffffff81027df1>] hpet_set_mode+0x111/0x15f
: [<ffffffff81027e53>] hpet_msi_set_mode+0x14/0x16
: [<ffffffff8107cafc>] clockevents_set_mode+0x20/0x4d
: [<ffffffff8107d22b>] tick_notify+0x337/0x37c
: [<ffffffff814ae429>] ? printk+0x51/0x53
: [<ffffffff814ba3cb>] notifier_call_chain+0x37/0x63
: [<ffffffff81074690>] raw_notifier_call_chain+0x14/0x16
: [<ffffffff8107c843>] clockevents_notify+0x3a/0xf9
: [<ffffffff81078666>] timekeeping_resume+0xc4/0xd2
: [<ffffffff812f82d0>] syscore_resume+0x6b/0xb3
: [<ffffffff8108966f>] suspend_devices_and_enter+0x14d/0x1d9
: [<ffffffff810897db>] enter_state+0xe0/0x137
: [<ffffffff81088e56>] state_store+0xaf/0xc5
: [<ffffffff81237f8b>] kobj_attr_store+0x17/0x19
: [<ffffffff8117fb0c>] sysfs_write_file+0x111/0x14d
: [<ffffffff81126e91>] vfs_write+0xac/0xf3
: [<ffffffff81127080>] sys_write+0x4a/0x6e
: [<ffffffff814bd7c2>] system_call_fastpath+0x16/0x1b

comment:
:Vanilla FC 15 install.  Latest updates installed.  I put the laptop (Lenovo W510) to sleep by pressing fn+F4.
:
:I then opened the screen to resume and was presented with this message.  Machine seems to be pretty much OK though, aside from the screen brightness control no longer works
Comment 1 Matt 2011-08-28 04:31:45 EDT
After the recent Kernel update (2.6.40.3-0.fc15.x86_64), this issue is still there.
Comment 2 Bernardo Barros 2011-09-15 15:01:02 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Laptop (thinkpad w510) uppluged with monitor down, maybe in sleep mode. When came back there was a kernel crash report.
Comment 3 Victor Ion Munteanu 2011-09-21 01:35:03 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Don't know
Comment 4 Ricardo Alves Teixeira 2011-10-01 08:32:10 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
I put the computer to sleep and when I started usind it again, not only this error appeared but also the brightness of the screen is set at the minimum possible and I am unable to change it via keyboard shortcuts.
Comment 5 Tom Fonteyne 2011-10-06 08:51:25 EDT
same problem here
Fedora 15 fully up to date with all updates
Comment 6 v 2011-10-11 02:32:53 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
On resume from hibernate
Comment 7 v 2011-10-11 07:02:10 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Resume failed after hibernate..system froze with blank screen..non-responsive..happens more than once..thought kernel update had solved it..

SERIOUS ISSUE
Comment 8 Roman Spirgi 2011-11-01 15:20:43 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
end sleep mode
Comment 9 fred 2011-11-04 14:50:52 EDT
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
playing voxatron, watch it crash and freeze my main screen, switch to a recovery tty, killl it, go back to my session,
restore screen properties with gnome screen properties, and see that an error popped.
Comment 10 Alex Tomic 2011-11-21 04:36:46 EST
Package: kernel
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
When restoring from suspend
Comment 11 Dave Jones 2012-04-11 11:49:04 EDT
*** Bug 765769 has been marked as a duplicate of this bug. ***
Comment 12 Dave Jones 2012-04-11 11:51:03 EDT
a number of these reports seem to be happening after hibernate.
That may be an indication this problem was caused by the i915 memory corruption bug that was recently fixed.

If any of you can reproduce this on 2.6.43.1, please let us know.
Otherwise, I'll close this in a few weeks.