Bug 728039

Summary: As of August 3, 2011, Network Manager does not recognize my wireless card
Product: [Fedora] Fedora Reporter: Greta Watson <greta_watson>
Component: NetworkManagerAssignee: Dan Williams <dcbw>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 15CC: dcbw
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-06 03:38:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Greta Watson 2011-08-04 01:23:40 UTC
Description of problem:  This morning, I was wirelessly connected using my laptop.  It did the updates, including updates to Network Manager.  After doing the updates, a restart was required.  After the restart, my laptop no longer connects to the internet.  ifconfig does not show wlan0 anymore.


Version-Release number of selected component (if applicable):
Aug 03 16:57:43 Updated: 1:NetworkManager-glib-0.8.9997-6.git20110721.fc15.x86_64
Aug 03 16:57:55 Updated: 1:NetworkManager-0.8.9997-6.git20110721.fc15.x86_64
Aug 03 16:58:16 Updated: 1:NetworkManager-vpnc-0.8.999-3.git20110721.fc15.x86_64
Aug 03 16:58:25 Updated: 1:NetworkManager-gnome-0.8.9997-6.git20110721.fc15.x86_64
Aug 03 16:58:44 Updated: 1:NetworkManager-pptp-0.8.999-2.git20110721.fc15.x86_64
Aug 03 16:58:49 Updated: 1:NetworkManager-openvpn-0.8.9997-2.git20110721.fc15.x86_64


How reproducible:
Boot up.  Shows an empty ethernet connection icon.  No wireless is shown.  ifconfig does not show information on wlan0

Steps to Reproduce:
1.boot up
2.ifconfig
3.look at networking icon
  
Actual results:
No connection


Expected results:
Wireless connection


Additional info:

Comment 1 Greta Watson 2011-08-04 04:56:05 UTC
In looking at /etc/init.d and /etc/rc.d/rc5.d, I noticed a bad symlink for S23NetworkManager in rc5.d.  There is no longer a file NetworkManager in init.d.

There are several other bad symlinks in those directories, including bluetoothd, smartd, restorecond, and udev-post.

Comment 2 Luke Hutchison 2011-08-05 00:55:42 UTC
Same problem after a recent update (maybe 2 weeks earlier than you though), except that I don't have missing symlinks.

I'm on F15 with an Intel 5100 wireless chip.

nm-applet says "Wireless is disabled", which it is not.  iwconfig does show wlan0 in my case even though nm-applet can't see it:

# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

ifconfig does not show wlan0 though.

Curiously, Ethernet and USB networking also do not come up unless they are plugged in on boot, and then they work fine.

Relevant lines from /var/log/messages:

Aug  2 17:38:44 localhost NetworkManager[851]: <info> found WiFi radio killswitch rfkill1 (at /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ieee80211/phy0/rfkill1) (driver (unknown))
Aug  2 17:38:44 localhost dbus-daemon: [system] Successfully activated service 'org.freedesktop.NetworkManager'
Aug  2 17:38:44 localhost NetworkManager[851]: <info> WiFi enabled by radio killswitch; disabled by state file
Aug  2 17:38:44 localhost NetworkManager[851]: <info> WWAN enabled by radio killswitch; enabled by state file
Aug  2 17:38:44 localhost NetworkManager[851]: <info> WiMAX enabled by radio killswitch; enabled by state file
Aug  2 17:38:44 localhost NetworkManager[851]: <info> Networking is enabled by state file
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): carrier is OFF
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): new Ethernet device (driver: 'e1000e' ifindex: 2)
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): now managed
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): bringing up device.
Aug  2 17:38:44 localhost modem-manager[1025]: <info>  ModemManager (version 0.4.998-1.git20110706.fc15) starting...
Aug  2 17:38:44 localhost dbus-daemon: [system] Successfully activated service 'org.freedesktop.ModemManager'
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): preparing device.
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (eth0): deactivating device (reason: 2).
Aug  2 17:38:44 localhost kernel: [   23.795083] ADDRCONF(NETDEV_UP): eth0: link is not ready
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): driver supports SSID scans (scan_capa 0x01).
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): new 802.11 WiFi device (driver: 'iwlagn' ifindex: 3)
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): exported as /org/freedesktop/NetworkManager/Devices/1
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): now managed
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): bringing up device.
Aug  2 17:38:44 localhost NetworkManager[851]: <info> (wlan0): deactivating device (reason: 2).
Aug  2 17:38:44 localhost NetworkManager[851]: <info> modem-manager is now available

Comment 3 Luke Hutchison 2011-08-05 05:30:24 UTC
Spoke too soon, this is fixed for me, as of tonight's Fedora 15 updates:

NetworkManager-0.8.9997-6.git20110721.fc15.x86_64.rpm
NetworkManager-glib-0.8.9997-6.git20110721.fc15.x86_64.rpm
NetworkManager-gnome-0.8.9997-6.git20110721.fc15.x86_64.rpm
wpa_supplicant-0.7.3-9.fc15.x86_64.rpm

Comment 4 Greta Watson 2011-08-05 21:07:38 UTC
After the peewee laptop (ASUS 1015pem with a broadcom BCM4311 wireless card) failed to connect, I updated another laptop (HP Pavilion zv5000z with Broadcom BCM4306 wireless controller).  After the update the second laptop functioned fine, with normal wireless capability using wlan1, an external wireless card, as the original had died.

To make sure it wasn't a dead wireless card on peewee, I tried a fresh install of Fedora 15 from a DVD I made on June 1.  Not only did the wireless not work, but the ethernet connection didn't work, either.  ifconfig gave some funky name, not eth0, and Network Manager couldn't find the ethernet card at all.

I then did a fresh install of Fedora 14 from a DVD made on February 17, and then installed kmod-wl, akmod-wl, and broadcom-wl.  After that install, Network Manager did not work for the wireless.  It saw the wireless card, but was unable to deal with the password needed to connect wirelessly.  Wicd was able to see the wireless card and did allow a wireless connection to the internet.

Thus, the card seems to be okay.  It is a combination wireless/bluetooth card, and both worked on Fedora 14.  One thing of note is that the installation of Fedora 14 used the name eth0 for the ethernet connection and eth1 for the wireless connection.

I next upgraded to Fedora 15, current versions of everything, which puts me back where I was when I submitted this bug:  no wireless.  So, I guess I'm going to have to re-install Fedora 14 until this is solved.

Comment 5 Luke Hutchison 2011-08-05 21:15:40 UTC
Broadcom chipsets are known to be problematic, you're probably lucky it worked for you on F14 at all ;)

Comment 6 Greta Watson 2011-08-06 03:38:44 UTC
As of this afternoon, in F14, the computer failed to connect wirelessly to the internet.  ifconfig showed the entries for ethernet (eth0) and wireless (eth1).  Wicd could see the wireless card but could not find any wireless networks, even though the router was only a couple feet away.  A re-install of F15 was no more successful than F14.

As the other person who had a problem says his problem no longer exists, and as I no longer think my problem is due to the system update, I feel I should close this bug.

One note, though.  Why did the ethernet connection get named p35p1 instead of eth0 when I installed a fresh F15?  Same software that gives funky names for usb devices and such?  To me, this is not movement in a forward direction.