Bug 728457

Summary: Remove virtio drivers for winxp 64 bit guest
Product: Red Hat Enterprise Linux 6 Reporter: Mike Cao <bcao>
Component: virtio-winAssignee: Vadim Rozenfeld <vrozenfe>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: high    
Version: 6.2CC: bcao, dawu, jgreguske, juzhang, mdeng, michen, qzhang
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Do not document.
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-12-06 21:17:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mike Cao 2011-08-05 08:17:09 UTC
Description of problem:
in virtio-win-1.3.2.iso ,I saw virtio nic/balloon/serial digital signed drivers listed for winxp 64 bit ,while QE never tried it in whql test as winxp 64 bit is not officially supported .

Version-Release number of selected component (if applicable):
# rpm -q virtio-win
virtio-win-1.3.2-1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.rpm -ivh virtio-win-1.3.2-1.el6.noarch.rpm
2.mount -o loop virtio-win-1.3.2.iso /opt
  
Actual results:
1. ls /opt/vioserial/xp/amd64/
vioser.cat  vioser.inf  vioser.sys  vioser-test.exe  WdfCoInstaller01009.dll
2. # ls /opt/Balloon/xp/amd64/
balloon.cat  balloon.inf  balloon.pdb  balloon.sys  blnsvr.exe  blnsvr.pdb  WdfCoInstaller01009.dll
3.#ls /opt/NetKVM/xp/amd64/
netkvm.cat  netkvm.inf  netkvm.pdb  netkvm.sys

Expected results:
all files described in actual results shouldn't be listed ,as QE did not do WHQL test for windows xp 64 bit 


Additional info:

Comment 1 Vadim Rozenfeld 2011-08-07 13:35:01 UTC
Hi Mike,

Could you please check this issue?
Seems like not only virtio-win-1.3.2-1 has 
this problem, but also 1.3.2-2 

Best regards,
Vadim.

Comment 7 Mike Cao 2011-08-10 02:40:10 UTC
Move back to assigned status since no builds for this bug fix

Comment 10 Mike Cao 2011-08-12 05:09:55 UTC
download the virtio-win-1.3.3-0.el6.noarch.rpm ,repeat steps in comment #0

Actual Results:
no directory for winxp 64 bit .
also check the files in virtio-win-1.3.3-0.el6.src.rpm .
still no directory for winxp 64 bit

Based on above ,this issue has been fixed.
Move status to VERIFIED.

Comment 11 Vadim Rozenfeld 2011-11-02 20:11:26 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Do not document.

Comment 12 errata-xmlrpc 2011-12-06 21:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1542.html