Bug 728693

Summary: Bacula: Logwatch logfile paths don't match with logrotate logfile paths
Product: Red Hat Enterprise Linux 6 Reporter: Robert Scheck <redhat-bugzilla>
Component: baculaAssignee: Lukáš Nykrýn <lnykryn>
Status: CLOSED ERRATA QA Contact: Tomas Dolezal <todoleza>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.4CC: azelinka, negativo17, ovasik, rdassen, robert.scheck, todoleza
Target Milestone: rc   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: bacula-5.0.0-10.el6 Doc Type: Bug Fix
Doc Text:
Cause: Logwatch does not check /var/log/bacula* Consequence: Not all information are shown in logwatch report. Fix: Add all logfiles to logwatch. Result: All information are shown in logwatch report.
Story Points: ---
Clone Of:
: 924797 (view as bug list) Environment:
Last Closed: 2012-11-19 04:14:58 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 782183, 836169, 840699, 924797    

Description Robert Scheck 2011-08-06 13:03:13 UTC
Description of problem:
By default, logwatch looks in "/etc/logwatch/conf/logfiles/bacula.conf" for
the existing bacula log files to check them:

[root@tux ~]# cat /etc/logwatch/conf/logfiles/bacula.conf 
# What actual file?  Defaults to LogPath if not absolute path....
LogFile = /var/spool/bacula/log

[root@tux ~]#

But "/etc/logrotate.d/bacula" which is used by logrotate is looking for the
log files of bacula at other paths:

[root@tux ~]# cat /etc/logrotate.d/bacula
# Bacula logrotate script

/var/log/bacula/*.log /var/spool/bacula/log /var/log/bacula.log {
    monthly
    rotate 4
    notifempty
    missingok
}

[root@tux ~]#

Version-Release number of selected component (if applicable):
bacula-director-common-5.0.0-7.el6.x86_64

How reproducible:
Everytime, see above and below.

Actual results:
Logwatch logfile paths don't match with logrotate logfile paths.

Expected results:
Logwatch logfile paths should match with logrotate logfile paths. Please
use the example below (or better) for solving this issue:

Additional info:
Putting the following into "/etc/logwatch/conf/logfiles/bacula.conf" solves
the issue:

--- snipp ---
# What actual file?  Defaults to LogPath if not absolute path....
LogFile = bacula.log
LogFile = bacula/*.log
LogFile = /var/spool/bacula/log

--- snapp ---

NOTE: I'm not a logwatch expert, I might have forgotten something, it's just
working for me.

Comment 1 Robert Scheck 2011-08-06 13:21:55 UTC
As we're experiencing the same problem, I have cross-filed case 00515384 in
the Red Hat customer portal.

Comment 3 RHEL Product and Program Management 2011-08-06 13:37:48 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Robert Scheck 2011-10-11 12:03:17 UTC
Filled as case 00545705 as well, because affects another customer, too.

Comment 5 Robert Scheck 2011-10-13 11:00:38 UTC
Same for case 00547365, yet another customer.

Comment 6 Simone Caronni 2012-01-24 08:49:04 UTC
Hello,

sorry for posting it here but I don't know how to file an RFC for the Bacula package.
Most of the bugs I find in bugzilla.redhat.com related to Bacula on RHEL are fixed upstream or in current Fedora 15/16/17 packages.

If someone can point me on how to create a request to a package update in RHEL I will be most grateful.

Here are the things that make the current Bacula unusable in my setups.

1) Windows backups
A combination of plugins and storage daemons make impossible to backup Windows machines that use the VSS plugin (mostly mandatory to make a succesful backup) and mirrored disks if the Windows File Daemon and servers are not at least version 5.0.3. I opened the bug to Bacula Systems (using the enterprise edition) and it was also fixed on the community edition a year ago with references to "Windows Junction points".

2) No file capabilities backup / restore
I have waited on this for long and it is now available. Files with file capabilities backed up and restored correctly with 5.2.4 or the bacula git branch of 5.0 (5.0.4?).
http://www.mail-archive.com/bacula-users@lists.sourceforge.net/msg50835.html

3) No POSIX.1e ReadAll file capabilities
RHEL package does not enable file capabilities in the build; I always used ReadAll file capabilities since version 5.0.0 on RHEL 5 and it works perfectly.

4) No bpipe-fd.so file daemon plugin
How can one backup any open database without this one?! Requires libtool enabled at build and it removes some patches as well.

5) No other features:
- Docs subpackage is marked with i386, x86_64 and not noarch, it's missing the HTML docs.
- No batch insert code enabled, it increases performance dramatically on large databases.
- No Nagios plugin.
- No LZO compression (useful for disk backups).
- Consolehelper does not make any sense (root password for local system if connecting to a remote backup server?). It should not be installed at all on user machines.
- No readline completion for bconsole; works perfectly since version 5.0.0 and eases a lot usage of bconsole.
- Some configuration is done at build time through patches and not at configuration time.

I'm the current co-mantainer of bacula packages, I can prepare a backported 5.0.3 package from Fedora 16 that does not use fedora-usermgmt for it (with static uid 133 already allocated also in RHEL), a 5.2.4 package (that can be rebuilt directly from rawhide, as it already doesn't use fedora-usermgmt) or a pre-5.0.4 release from Bacula git.

http://pkgs.fedoraproject.org/gitweb/?p=bacula.git;a=summary
http://pkgs.fedoraproject.org/gitweb/?p=bacula-docs.git;a=summary
http://repos.fedorapeople.org/repos/slaanesh/bacula/README.txt

Many thanks,
--Simone

Comment 9 RHEL Product and Program Management 2012-07-10 06:39:12 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 10 Simone Caronni 2012-07-10 12:16:08 UTC
In addition to the above missing features, the current release of Bacula has the following:

- Extended attribute backup and restore on all filesystems supported by rhel, including xfs and btfrs (available since 5.2.8).
- Simpler mechanism for choosing the database backend through a single entry in the alternatives subsystem and not with multiple binaries.
- Less patching and removal of deprecated components and commands.
- *Huge* number of bugs solved directly by the upstram projects; connections management, stability, internal logic for jobs, filesystem support bugs, etc.

The links above are still actual.

Regards,
--Simone

Comment 11 RHEL Product and Program Management 2012-07-10 23:06:01 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 14 Ondrej Vasik 2012-07-16 11:10:55 UTC
Simone: Thanks for the suggestion and for all your work on bacula in Fedora, but update of bacula in RHEL-6 to latest greatest version is unlikely at the moment. 

If you still want to make this proposal for Rebase, please open new bugzilla ticket against RHEL-6 product and bacula component. Adding something like comments #6/#10 to this bugzilla will not help anything.

Comment 20 errata-xmlrpc 2012-11-19 04:14:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1469.html