Bug 728803

Summary: drupal6-video bundles external source, possibly copylibs
Product: [Fedora] Fedora Reporter: Paul W. Frields <stickster>
Component: drupal6-videoAssignee: Jon Ciesla <limburgher>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: limburgher, pfrields, stickster, tcallawa, tla
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-07 08:40:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 182235    

Description Paul W. Frields 2011-08-07 13:56:21 EDT
In the video-6.x.4.2 source, the following files look like bundled libraries. They may be copylibs but they should be extracted and packaged separately if not.

plugins/video_s3/includes/S3.php
js/flowplayer-3.2.0.min.js
js/jquery.media.js
js/jquery.metadata.js

This may have been overlooked in the original review.
Comment 1 Jon Ciesla 2012-07-24 15:52:49 EDT
Just updated rawhide to 5.2, which removes the first.  I'll keep digging.
Comment 2 Jon Ciesla 2012-07-25 11:08:28 EDT
flowplayer is unmodified from the 3.2.0 version, 3.2.12 is current.  I'll see about packaging it.
Comment 3 Jon Ciesla 2012-07-25 11:11:20 EDT
jquery.media.js is from:

http://malsup.com/jquery/media/

It's an old version, and they don't do releases.
<headdesk>
Comment 4 Jon Ciesla 2012-07-25 11:13:55 EDT
jquery.metadata.js is from:

http://archive.plugins.jquery.com/project/metadata

I *think* it's the latest release.
Comment 5 Jon Ciesla 2012-07-30 12:48:11 EDT
I'm not sure we can package flowplayer, the license is GPLv3 with log restrictions.

http://flowplayer.org/download/licenses/license_gpl.html

Flagging FE-LEGAL, we may need to just drop drupal6-video.
Comment 6 Tom "spot" Callaway 2012-08-03 11:03:41 EDT
Red Hat legal advises that the flowplayer license is non-free, because of the unconventional exceptions to the GPLv3.
Comment 7 Paul W. Frields 2012-08-03 12:18:41 EDT
A quick look at the code tells me that stripping out the flowplayer module wouldn't make the module useless.  AFAIK this module is not necessary for any current or planned projects in Fedora, though, so if major reworking is required, I wouldn't oppose dropping it.
Comment 8 Jon Ciesla 2012-08-06 13:38:15 EDT
If it were just flowplayer I'd work on it, but since there's also the two jquery bits, and it's a drupal6 module, not drupal7, and we don't *really* need it, I'll drop, unless you want it, Paul.
Comment 9 Tom "spot" Callaway 2012-08-06 13:45:00 EDT
Worth noting that Javascript is exempt from the no-bundling rules.
Comment 10 Jon Ciesla 2012-08-06 13:47:23 EDT
Is it?  I thought I remembered that, but couldn't find it specifically.
Comment 12 Jon Ciesla 2012-08-06 13:59:29 EDT
Ah, there, thanks.  Needed to zoom out a bit. :)  Of course, I still don't love doing it, so I'll drop unless Paul wants it.
Comment 13 Jon Ciesla 2012-08-06 14:00:13 EDT
Maybe.  Thinking about it.
Comment 14 Jon Ciesla 2012-08-07 08:40:32 EDT
Looks like flowplayer is non-trivial to pull out, I'll retire this.