Bug 729035

Summary: Debuginfo package issues in pacemaker
Product: Red Hat Enterprise Linux 6 Reporter: Karel Klíč <kklic>
Component: pacemakerAssignee: Andrew Beekhof <abeekhof>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: low Docs Contact:
Priority: low    
Version: 6.3CC: cluster-maint, jkortus, rvokal
Target Milestone: rcKeywords: TechPreview
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: pacemaker-1.1.7-1.el6 Doc Type: Technology Preview
Doc Text:
Pacemaker, a scalable high-availability cluster resource manager, is included in Red Hat Enterprise Linux 6 as a Technology Preview. Pacemaker is not fully integrated with the Red Hat cluster stack.
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-20 09:48:37 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 727919, 756082    

Description Karel Klíč 2011-08-08 11:20:25 EDT
Several problems related to debuginfo were found in the pacemaker-1.1.5-5.el6 package. These issues might affect crash analysis done by Automatic Bug Reporting Tool and its retrace server, and also prevent proper debugging of crashes via GDB.

Unused debuginfo files
----------------------
The debuginfo package contains a superfluous file with debugging symbols. This is usually caused by using %exclude in package's spec file instead of deleting the unwanted binary from the build root. This is a low priority issue, unnecessary files cause no harm except wasted space.

debuginfo path: pacemaker-debuginfo-1.1.5-5.el6.i686/usr/lib/debug/.build-id/f7/372101b8841c6daadcde2c3f0793d2ec686078
associated (missing) binary: /usr/sbin/crm_uuid
wasted disk space: 107.0 kB

No .debug_info section in a debug file
--------------------------------------
When a binary is compiled without gcc's -g option, no debugging information is generated and rpmbuild creates almost-empty debuginfo file, which cannot be used for debugging. Please fix the package build process to use $RPM_OPT_FLAGS, which include the -g option among others.

path: /usr/lib/debug/usr/libexec/lcrso/pacemaker.lcrso.debug
package: pacemaker-debuginfo-1.1.5-5.el6.i686

This issue can be investigated and tested by using eu-readelf tool from the elfutils package. Use `eu-readelf --section-headers /usr/lib/debug/usr/bin/<debuginfofile>.debug` to see if debuginfo file contains .debug_info section. It is supposed to be there.

(This bug was detected and filed by a script.)
Comment 9 Lon Hohberger 2011-09-28 16:46:23 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Pacemaker continues to be a Technology Preview in Red Hat Enterprise Linux 6.2
Comment 10 Jaroslav Kortus 2011-10-13 11:16:43 EDT
the section is still missing:

$ eu-readelf --section-headers /usr/lib/debug/usr/libexec/lcrso/pacemaker.lcrso.debug
There are 29 section headers, starting at offset 0x3828:

Section Headers:
[Nr] Name                 Type         Addr             Off      Size     ES Flags Lk Inf Al
[ 0]                      NULL         0000000000000000 00000000 00000000  0        0   0  0
[ 1] .note.gnu.build-id   NOTE         0000000000000190 00000190 00000024  0 A      0   0  4
[ 2] .gnu.hash            NOBITS       00000000000001b8 000001b8 00000290  0 A      3   0  8
[ 3] .dynsym              NOBITS       0000000000000448 000001b8 00000dc8 24 A      4   2  8
[ 4] .dynstr              NOBITS       0000000000001210 000001b8 00000836  0 A      0   0  1
[ 5] .gnu.version         NOBITS       0000000000001a46 000001b8 00000126  2 A      3   0  2
[ 6] .gnu.version_r       NOBITS       0000000000001b70 000001b8 00000020  0 A      4   1  8
[ 7] .rela.dyn            NOBITS       0000000000001b90 000001b8 00000780 24 A      3   0  8
[ 8] .rela.plt            NOBITS       0000000000002310 000001b8 00000858 24 A      3  10  8
[ 9] .init                NOBITS       0000000000002b68 000001b8 00000018  0 AX     0   0  4
[10] .plt                 NOBITS       0000000000002b80 000001b8 000005a0 16 AX     0   0  4
[11] .text                NOBITS       0000000000003120 000001c0 0000a7c8  0 AX     0   0 16
[12] .fini                NOBITS       000000000000d8e8 000001c0 0000000e  0 AX     0   0  4
[13] .rodata              NOBITS       000000000000d900 000001c0 00002b16  0 A      0   0 16
[14] .eh_frame_hdr        NOBITS       0000000000010418 000001c0 0000028c  0 A      0   0  4
[15] .eh_frame            NOBITS       00000000000106a8 000001c0 00000bdc  0 A      0   0  8
[16] .ctors               NOBITS       0000000000211288 000001c0 00000028  0 WA     0   0  8
[17] .dtors               NOBITS       00000000002112b0 000001c0 00000010  0 WA     0   0  8
[18] .jcr                 NOBITS       00000000002112c0 000001c0 00000008  0 WA     0   0  8
[19] .data.rel.ro         NOBITS       00000000002112c8 000001c0 00000008  0 WA     0   0  8
[20] .dynamic             NOBITS       00000000002112d0 000001c0 00000240 16 WA     4   0  8
[21] .got                 NOBITS       0000000000211510 000001c0 000000f0  8 WA     0   0  8
[22] .got.plt             NOBITS       0000000000211600 000001c0 000002e0  8 WA     0   0  8
[23] .data                NOBITS       00000000002118e0 000001c0 00000520  0 WA     0   0 32
[24] .bss                 NOBITS       0000000000211e00 000001c0 00000150  0 WA     0   0 32
[25] .comment             PROGBITS     0000000000000000 000001c0 0000002c  1 MS     0   0  1
[26] .shstrtab            STRTAB       0000000000000000 000001ec 000000f5  0        0   0  1
[27] .symtab              SYMTAB       0000000000000000 000002e8 00001f50 24       28 189  8
[28] .strtab              STRTAB       0000000000000000 00002238 000015ed  0        0   0  1

(10:13:31) [root@marathon-03:~]$ rpm -q pacemaker
pacemaker-1.1.6-2.el6.x86_64

for file in `rpm -ql pacemaker-debuginfo | grep -E '.debug$' `; do eu-readelf --section-headers $file | grep -q .debug_info || echo "$file is bad"; done

/usr/lib/debug/.build-id/17/2768d0ba79d901948ae87d5593acab4dfbfce5.debug is also affected.
Comment 13 Andrew Beekhof 2011-10-17 17:23:19 EDT
Oh I see.  Somehow I managed to only see the first part of this bug.
We do build with -g, I wonder why the corosync plugin doesn't contain the symbols.
Comment 14 Lon Hohberger 2011-10-18 10:12:47 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Pacemaker continues to be a Technology Preview in Red Hat Enterprise Linux 6.2+Pacemaker continues to be a Technology Preview in Red Hat Enterprise Linux 6.3
Comment 16 Martin Prpic 2011-11-10 08:00:41 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Pacemaker continues to be a Technology Preview in Red Hat Enterprise Linux 6.3+Pacemaker, a scalable high-availability cluster resource manager, is included in Red Hat Enterprise Linux 6 as a Technology Preview. Pacemaker is not fully integrated with the Red Hat cluster stack.
Comment 19 Andrew Beekhof 2012-02-14 21:31:13 EST
A related patch has been committed upstream: https://github.com/beekhof/pacemaker/commit/57203e5
Comment 23 Jaroslav Kortus 2012-04-05 10:19:50 EDT
for file in `rpm -ql pacemaker-debuginfo | grep -E '.debug$' `; do eu-readelf --section-headers $file | grep -q .debug_info || echo "$file is bad"; done

empty list

and
 eu-readelf --section-headers /usr/lib/debug/usr/libexec/lcrso/pacemaker.lcrso.debug | grep debug_info
[28] .debug_info          PROGBITS     00000000 000744 0075d4  0        0   0  1

so all seems to be fixed now.

pacemaker-1.1.7-5.el6.i686
pacemaker-1.1.7-5.el6.x86_64
Comment 25 errata-xmlrpc 2012-06-20 09:48:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0846.html