Bug 729457

Summary: Error installing the bootloader-the system may not be bootable
Product: [Fedora] Fedora Reporter: Clyde E. Kunkel <clydekunkel7734>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 16CC: anaconda-maint-list, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-09 22:04:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
contents of /tmp directory with bootloader error showing none

Description Clyde E. Kunkel 2011-08-09 19:38:05 UTC
Created attachment 517472 [details]
contents of /tmp directory with bootloader error showing

Description of problem:
At the end of the installation of FC16RC1 an error dialogue box popped up saying:

Warning.
There was an error installing the bootloader. The system may not be bootable.

Version-Release number of selected component (if applicable):
16.14.2

How reproducible:
every time

Steps to Reproduce:
1.boot F16 Alpha RC DVD with anaconda 16.14.2
2.select /dev/sda11 as /boot
3.select install bootloadfer on /dev/sda11
4.proceed with the install
5.at the end get error as above
  
Actual results:
cant boot system using root (hd0,10) and chainloader +1

Expected results:
chainload to F16 boot partition and boot F16

Additional info:
No other error msgs noted.  Attaching everything in /tmp dir.

By creating an entry in a F15 grub.conf using old grub nomenclature, can boot F16.  During other installs of F16 from desktop spins have had success with grub2-install by specifying --force.  Then chainloader +1 works.  However, this has proved to be dangerous as have borked a different setup using the instructions (probably wrongly) in http://fedoraproject.org/wiki/Features/Grub2.

My assumption is that currently anaconda believes /boot is on the first parition.  When it isn't, as is my test case, the error occurs.

Comment 1 David Lehman 2011-08-09 22:04:56 UTC
At this time it seems as though grub2 will refuse to install to any partition without --force.

What makes you think anaconda believes /boot is on the first partition? (Especially given that it was anaconda that set up /boot on sda11)

*** This bug has been marked as a duplicate of bug 728742 ***

Comment 2 Clyde E. Kunkel 2011-08-10 02:31:35 UTC
Just an assumption in trying to understand what was happening, nothing concrete.

I tried grub2-install --grub-setup=/bin/true /dev/sda11, then sda and then sda3 (actual first linux style parition that is being used to boot all distros and windows).  None worked, but then I didn't use --force since I was bitten earlier by it.

Comment 3 Clyde E. Kunkel 2011-08-10 03:03:10 UTC
Ran grub2-install --force /dev/sda11 and can now chainload to grub2 bootloader on sda11.  Note that --grub-setup=/bin/true has to be omitted.