Bug 730405

Summary: Libtiff-dev is missing some header files
Product: Red Hat Enterprise Linux 6 Reporter: Mark Jones <mark0978>
Component: libtiffAssignee: Tom Lane <tgl>
Status: CLOSED NOTABUG QA Contact: qe-baseos-daemons
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.3CC: hhorak
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-10-21 04:12:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mark Jones 2011-08-12 19:32:52 UTC
Description of problem:
I need group4 decode in the Python Imaging Library, but in order to build it, I need to get some changes put into the distros libtiff-dev packages.

Currently the following files are added /usr/include or /usr/local/include

/usr/include/tiffconf.h  
/usr/include/tiff.h  
/usr/include/tiffio.h  
/usr/include/tiffio.hxx  
/usr/include/tiffvers.h

I also need:

/usr/include/tif_config.h  
/usr/include/tif_dir.h
/usr/include/tiffiop.h

The patch in PIL I had to use to get all this going is from 2006 and is made against the 1.1.6 PIL library (PIL is now at 1.1.7), but I'm pretty sure I can't get these patches for PIL into pyPI distribution if it won't build in the distros.

After this is done here, I can push to get the fix into PIL.

Version-Release number of selected component (if applicable):
All back to 2006 (at least)

How reproducible:
Very
https://www.kuro5hin.org/story/2010/4/15/133252/616

Steps to Reproduce:
1. install libtiff-dev
2.
3.
  
Actual results:
Those 3 files are not present

Expected results:
Those 3 files are present

Additional info:
I also have to get debian to add those files too.

Comment 2 Tom Lane 2011-08-12 19:54:27 UTC
Uh ... the reason tiffiop.h isn't exported is that it's *private*.  Any application depending on its contents is not supportable because it will break with foreseeable library changes.  Not sure about the other two offhand, but I will not export that one.

As near as I can tell, the link you provide is to somebody's crude hack, not a supportable fix for PIL.  It should not be necessary to look into the library's private definitions in order to have G4 support.

Comment 3 RHEL Product and Program Management 2011-08-12 20:08:02 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.