Bug 730424

Summary: opening .torrent files doesn't work
Product: [Fedora] Fedora Reporter: Pierre Ossman <pierre-bugzilla>
Component: delugeAssignee: Rahul Sundaram <metherid>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 14CC: ggillies, justinnoah, metherid
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: deluge-1.3.3-1.fc14 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-26 19:03:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Pierre Ossman 2011-08-12 20:52:38 UTC
Description of problem:
Opening a .torrent file does not work with deluge. Deluge complains about not being able to open the file.

Version-Release number of selected component (if applicable):
deluge-1.3.2-1.fc14.noarch


How reproducible:
Every time.


Steps to Reproduce:
1. Click a .torrent file in firefox.
  

Actual results:
Deluge complains about not finding the file.


Expected results:
New torrent is added to deluge.


Additional info:
The issue is caused by the deluge .desktop file specifying it wants a URI, not a path as an argument. It therefore gets e.g. "file:/tmp/foo.torrent" instead of "/tmp/foo.torrent" (which works). I assume this was done to handle magnet links, so you can't just switch back to providing paths.

Either deluge needs to learn how to deal with file://, or you'll have to have two .desktop files, one for .torrent files and one for magnet links.

Comment 1 Pierre Ossman 2011-08-15 06:43:51 UTC
Seems like this is fixed in 1.3.3, looking at the changelog:

http://dev.deluge-torrent.org/wiki/ChangeLog

"# Fix path error with torrent files prefixed with ' file://' from Firefox"

Comment 2 Fedora Update System 2011-08-15 14:24:09 UTC
deluge-1.3.3-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/deluge-1.3.3-1.fc14

Comment 3 Fedora Update System 2011-08-17 01:00:23 UTC
Package deluge-1.3.3-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing deluge-1.3.3-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/deluge-1.3.3-1.fc14
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-08-26 19:03:06 UTC
deluge-1.3.3-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.