Bug 730677

Summary: Accelerator keys issues
Product: [Community] Virtualization Tools Reporter: Alexander Todorov <atodorov>
Component: virt-managerAssignee: Cole Robinson <crobinso>
Status: CLOSED UPSTREAM QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: unspecifiedCC: berrange, crobinso, jwu, mzhan, rwu, xen-maint, zpeng
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-01-30 02:15:02 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 691780    

Description Alexander Todorov 2011-08-15 11:04:15 UTC
Description of problem:
In the Add New Virtual Hardware window, Storage selection I tried using accelerator keys instead of clicking the mouse and I noticed several issues

1) "Create disk image ..." label and "Browse" button have the same accelerator key Alt+R
2) "Select managed ..." and "Cache mode" have the same accel key: Alt+M
3) "Storage format" and "Finish" have the same accel key: Alt+F
4) Alt+F selects only the Finish button, other duplicate accel keys cycle through widgets
5) Alt+D doesn't work for "Device type"
6) Using some of the duplicated accel keys does select the widget but doesn't perform an action on it (i.e. select or press button). This is probably due to the fact that accel keys are duplicated. 
7) The other hardware types windows have similar issues too

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-5.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Create new guest and customize the config. 
2. Open the add new hardware window and select to add storage.

Comment 1 Cole Robinson 2011-09-27 18:33:04 UTC
Not a huge priority so deferring to 6.3

Comment 3 Cole Robinson 2011-12-09 23:06:35 UTC
Not urgent, and given reduced capacity for virt-manager/virtinst, just moving
this to the upstream tracker.