Bug 730773

Summary: services --enabled=ssh seems to get ignored in appliance-tools
Product: Red Hat Enterprise Linux 6 Reporter: Jay Greguske <jgreguske>
Component: appliance-toolsAssignee: Brian Lane <bcl>
Status: CLOSED WONTFIX QA Contact:
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.3CC: mikeb
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-04-17 13:14:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jay Greguske 2011-08-15 17:59:10 UTC
Description of problem:

Running appliance-tools with a kickstart that has services "--enabled=network,sshd,rsyslog" seems to fail at actually opening the port(s).


Version-Release number of selected component (if applicable):
appliance-tools-004.5-5.el6

How reproducible:
Always

Steps to Reproduce:
1. Run appliance tools with a kickstart that has the aforementioned line.
2. Boot the resultant disk image as a VM guest
3. Attempt to SSH in
  
Actual results:
Cannot ssh into a booted guest that was build by appliance-tools.

Expected results:
Should be able to ssh into a booted guest that was build by appliance-tools.

Comment 1 Jay Greguske 2011-08-15 18:02:45 UTC
It's also worth noting that in the image there are the following files:

/etc/sysconfig/iptables.old
/etc/sysconfig/ip6tables.old
/etc/sysconfig/system-config-firewall.old

I'm guessing configuration changes are being made, just not being properly persisted, or getting smashed later in the image building process.

Comment 3 RHEL Product and Program Management 2011-08-15 18:27:55 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Jay Greguske 2012-04-17 13:14:36 UTC
Killing off languishing bugs. Worked around this issue for over a year and don't care if it is fixed in appliance-tools anymore. If media-creator has it I'll file a new one.