Bug 731897

Summary: anaconda installed device-mapper-multipath package, but /etc/multipath didn't exist.
Product: [Fedora] Fedora Reporter: Ben Marzinski <bmarzins>
Component: anacondaAssignee: Ales Kozumplik <akozumpl>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: akozumpl, anaconda-maint-list, jonathan, jzeleny, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-19 11:38:44 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
kickstart file used to install the system.
none
install.log from the system.
none
install.log.syslog from the system.
none
kickstart none

Description Ben Marzinski 2011-08-18 23:29:07 UTC
Created attachment 518954 [details]
kickstart file used to install the system.

Description of problem:
The device-mapper-multipath rpm creates the /etc/multipath directory when it is installed.  However, when I installed F15, the device-mapper-multipath package
was installed by anaconda, but the /etc/multipath directory didn't exist.

Version-Release number of selected component (if applicable):
Err. How do you find out what version of anaconda installed your system after the fact.  I'd rather not have to reinstall to find that out.

How reproducible:
Haven't tried

Steps to Reproduce:
1. install with attached kickstart file.
2.
3.
  
Actual results:
device-mapper-multipath was installed. /etc/multipath didn't exist

Expected results:
If device-mapper-multipath was installed, etc/multipath should exist.

Additional info:

Comment 1 Ben Marzinski 2011-08-18 23:32:25 UTC
Created attachment 518955 [details]
install.log from the system.

Comment 2 Ben Marzinski 2011-08-18 23:32:58 UTC
Created attachment 518956 [details]
install.log.syslog from the system.

Comment 3 Brian Lane 2011-08-18 23:58:18 UTC
Please attach the logs from /var/log/anaconda/* to this bug as individual plain/text files (bugzilla's autodetect doesn't work well with logs). You can see the anaconda version at the top of the anaconda.log file.

Comment 4 Ales Kozumplik 2011-08-19 11:38:44 UTC
Tried this with F16 RC5 and the attached kickstart. The directory /etc/multipath does exist on the installed system. Closing, please try with f16 and reoopen with the logs requested above if you can still see the problem.

Comment 5 Ales Kozumplik 2011-08-19 11:39:44 UTC
Created attachment 519021 [details]
kickstart