Bug 731961

Summary: microcode.ko does not support AMD family 15
Product: [Fedora] Fedora Reporter: Vittorio <vitti570>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: 15CC: aquini, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, vitti570
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-20 09:00:17 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Vittorio 2011-08-19 09:32:34 UTC
Description of problem:
I just installed kernel-2.6.40.3-0.fc15.x86_64.rpm
on my AMD Athlon 64 3500+ family 15.

Unfortunately the kernel crashes at boot time issuing a lot of messages

microcode: CPU0: family 15 not supported


It seems that microcode.ko does not support family 15 AMD processors.

I fixed the issue substituting line 79 of microcode_amd.c


      if (c->x86_vendor != X86_VENDOR_AMD || c->x86 < 0x10) {


with the following


      if (c->x86_vendor != X86_VENDOR_AMD || c->x86 < 0x0F) {


After regenerating microcode.ko the kernel boots just fine.

First time I got this situation was with 2.6.40-4.

Until 2.6.38.8-35 everything was fine. I never installed 2.6.39.

Is this the correct fix or can you suggest me a better one?


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Josh Boyer 2011-08-19 11:56:45 UTC
What version of microcode_ctl do you have installed?  This is likely a dupe of bug 690930.  You need:

1. microcode_ctl-1.17-18.fc15
2. kernel-2.6.40.3-0.fc15

Comment 2 Vittorio 2011-08-20 09:00:17 UTC
Yes, installing microcode_ctl-1.17-18 fixed the issue.