Bug 732260

Summary: hsqldb fails to start due to invalid symlink
Product: [Fedora] Fedora Reporter: Frank Crawford <frank>
Component: hsqldbAssignee: Tomas 'Sheldon' Radej <tradej>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: akurtako, fnasser, frank, tradej
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: hsqldb-1.8.1.3-4.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-21 02:37:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Frank Crawford 2011-08-21 10:40:49 UTC
Description of problem:
/etc/init.d/hsqldb start or systemctl equivalent fails to start due to an invalid symlink

Version-Release number of selected component (if applicable):
hsqldb-1.8.1.3-3.fc15.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install hsqldb package
2. Run /etc/init.d/hsqldb start
3.
  
Actual results:
The message
JAVA_EXECUTABLE or HSQLDB_JAR_PATH in '/etc/sysconfig/hsqldb' is set to a non-file.

is printed and daemon is not started

Expected results:
Start the daemon.

Additional info:
The issue is that the installed symlink for /var/lib/hsqldb/lib/hsqldb.jar references itself.  Possibly this should link to /usr/share/java/hsqldb.jar.

Comment 1 Alexander Kurtakov 2012-03-07 12:46:33 UTC
Tomas, 
Would you please look into this one?

Comment 2 Tomas 'Sheldon' Radej 2012-03-08 13:50:11 UTC
Sure.

Comment 3 Fedora Admin XMLRPC Client 2012-03-08 15:39:06 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Fedora Update System 2012-03-08 16:38:54 UTC
hsqldb-1.8.1.3-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/hsqldb-1.8.1.3-4.fc15

Comment 5 Tomas 'Sheldon' Radej 2012-03-08 17:04:08 UTC
To Frank: Please see if the build works for you. Thank you.

Comment 6 Fedora Update System 2012-03-08 21:22:34 UTC
Package hsqldb-1.8.1.3-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hsqldb-1.8.1.3-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3403/hsqldb-1.8.1.3-4.fc15
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2012-03-21 02:37:49 UTC
hsqldb-1.8.1.3-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.