Bug 732565

Summary: screensaver won't start
Product: [Fedora] Fedora EPEL Reporter: Dimitri Maziuk <dmaziuk>
Component: xfce4-settingsAssignee: Kevin Fenzi <kevin>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: el6CC: kevin, maxamillion
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-03 02:49:31 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dimitri Maziuk 2011-08-22 22:31:02 UTC
Not sure if this belongs in settings or power manager.

Description of problem:

Screensaver does not start & does not lock screen. Power manager does kick in later and turns off the monitor, but the screen remains unlocked.

Version-Release number of selected component (if applicable):

xfce4-settings-4.8.2-2.el6.x86_64
xfce4-power-manager-1.0.10-1.el6.x86_64

How reproducible:

always.

Comment 1 Kevin Fenzi 2011-08-22 22:37:13 UTC
Is xscreensaver installed? Is it running?

Comment 2 Dimitri Maziuk 2011-08-22 22:44:47 UTC
gnome-screensaver was installed and running, xscreensaver wasn't (installing it now)

Comment 3 Kevin Fenzi 2011-08-22 22:51:32 UTC
Sadly, you can't use newer gnome-screensaver with Xfce. 

They switched to using a gnome-session related ping to determine idle time, so it would never trigger under Xfce. ;(

Comment 4 Dimitri Maziuk 2011-08-22 23:00:38 UTC
Then there should probably be a dependency on xscreensaver somewhere...

Anyway, I'm not getting much luck with xscreensaver either:

dmaziuk@yellowtail:~$ ps -aef | grep screen
dmaziuk   8168  8078  0 17:49 ?        00:00:00 xscreensaver -no-splash
dmaziuk   8752  8749  0 17:57 pts/1    00:00:00 grep screen
dmaziuk@yellowtail:~$

I had it set up to kick in after 2 minutes ("cosmos") and the screen was still unlocked 5 minutes later.

Comment 5 Dimitri Maziuk 2011-08-22 23:04:40 UTC
One more thing: the panel button worked before and fired up cosmos screensaver. Now it's starting xscreensaver with whatever its default selection happens to be -- so it seems the selection in settings widget works with gnome-screensaver, but not with xscreensaver.

Comment 6 Dimitri Maziuk 2011-08-22 23:36:31 UTC
OK, it appears the problem is that settings widget isn't actually doing anything.

I used it set cosmos screen saver to kick in after 15 minutes. I then used xscreensaver-demo to choose an ant screensaver, kick in after 2 minutes, and lock screen after another minute.

I came back 5 minutes later & I had ants crawling over my screen & it was locked.

Comment 7 Kevin Fenzi 2011-08-23 01:40:35 UTC
Are you sure that gnome-screensaver is not running at all? 

Which exact settings widget are you using? can you find it via 'ps' ?

Comment 8 Dimitri Maziuk 2011-08-23 16:47:01 UTC
Aha. So clicking on Settings - Screensaver in the menu fires up gnome-screensaver-preferences. Going through Settings - Settings Manager - Screensaver does fire up xscreensaver-demo.

Comment 9 Kevin Fenzi 2013-02-03 02:49:31 UTC
So, this is all solved now?

Feel free to re-open if there's anything further needed.