Bug 732649

Summary: yumdownloader --source ... tracebacks
Product: Red Hat Enterprise Linux 6 Reporter: Milos Malik <mmalik>
Component: yum-utilsAssignee: James Antill <james.antill>
Status: CLOSED DUPLICATE QA Contact: Karel Srot <ksrot>
Severity: high Docs Contact:
Priority: unspecified    
Version: 6.2CC: ksrot, toracat, zpavlas
Target Milestone: rcKeywords: Regression
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-13 10:38:09 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 743047    

Description Milos Malik 2011-08-23 08:10:20 UTC
Description of problem:


Version-Release number of selected component (if applicable):
yum-utils-1.1.30-7.el6.noarch

How reproducible:
always

Steps to Reproduce:
# yumdownloader --source libsepol
  
Actual results:
# yumdownloader --source libsepol
Loaded plugins: product-id, refresh-packagekit
Traceback (most recent call last):
  File "/usr/bin/yumdownloader", line 322, in <module>
    util = YumDownloader()
  File "/usr/bin/yumdownloader", line 73, in __init__
    self.main()
  File "/usr/bin/yumdownloader", line 99, in main
    self.setupSourceRepos()
  File "/usr/bin/yumdownloader", line 118, in setupSourceRepos
    repos_source += self.repos.findRepos('*-source-rpms')
UnboundLocalError: local variable 'repos_source' referenced before assignment
#

Expected results:
* no traceback
* libsepol source RPM is downloaded

Comment 2 Milos Malik 2011-08-23 08:16:52 UTC
yumdownloader from yum-utils-1.1.30-6.el6.noarch.rpm works as expected.

Comment 5 James Antill 2011-08-23 14:37:21 UTC
 Stupid moved code around bug. Just change the code from:

+        if rhn_source_repos: # RHN
+            repos_source += self.repos.findRepos('*-source-rpms')
+        repos_source = self.repos.findRepos('*-source')


...to:

+        repos_source = self.repos.findRepos('*-source')
+        if rhn_source_repos: # RHN
+            repos_source += self.repos.findRepos('*-source-rpms')

Comment 6 Zdeněk Pavlas 2011-09-13 08:23:35 UTC
Added BZ-732649-repos_source-traceback.patch

Comment 7 Zdeněk Pavlas 2011-09-13 10:36:45 UTC
Merged into BZ-710469-rhn-source-repos.patch.

Comment 8 Zdeněk Pavlas 2011-09-13 10:38:09 UTC

*** This bug has been marked as a duplicate of bug 710469 ***