Bug 732926

Summary: libmpichxx.so not linked correctly
Product: [Fedora] Fedora Reporter: Jayesh Badwaik <jayesh.badwaik90>
Component: mpich2Assignee: Deji Akingunola <dakingun>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 15CC: dakingun
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: mpich2-1.4.1p1-1.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-09-13 05:53:48 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jayesh Badwaik 2011-08-24 07:49:09 UTC
Description of problem:
When I tried to compile parmetis, I get the following error

/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `operator delete[](void*)'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `operator new(unsigned long)'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `operator delete(void*)'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `operator new[](unsigned long)'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `__cxa_pure_virtual'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `__cxa_allocate_exception'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `__gxx_personality_v0'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `__cxa_throw'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/lib64/mpich2/lib/libmpichcxx.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
collect2: ld returned 1 exit status



Version-Release number of selected component (if applicable):
mpich2-1.4-1.fc15

How reproducible:
Everytime

Steps to Reproduce:
1.Try to compile parmetis-4.0
2. 
3.
  
Actual results:


Expected results:
should compile peacefully

Additional info:

Comment 1 Jayesh Badwaik 2011-08-24 10:33:52 UTC
output of ldd -r libmpichxx.so 

jayesh@mowglie1990:lib$ ldd -r libmpichcxx.so
        linux-vdso.so.1 =>  (0x00007fff294af000)
        libmpich.so.3 => /usr/lib64/mpich2/lib/libmpich.so.3 (0x00007f6c76b1d000)
        librt.so.1 => /lib64/librt.so.1 (0x00007f6c768f6000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f6c766db000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f6c764c6000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f6c7612b000)
        /lib64/ld-linux-x86-64.so.2 (0x0000003c70400000)
undefined symbol: MPL_trfree    (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_env2str   (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trlevel   (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trvalid   (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trmalloc  (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trspace   (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_env2range (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trcalloc  (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_env2int   (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trdump    (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_env2bool  (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trstrdup  (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trrealloc (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_TrSetMaxMem       (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trinit    (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trDebugLevel      (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: MPL_trid      (/usr/lib64/mpich2/lib/libmpich.so.3)
undefined symbol: _ZTVN10__cxxabiv117__class_type_infoE (./libmpichcxx.so)
undefined symbol: _ZTVN10__cxxabiv120__si_class_type_infoE      (./libmpichcxx.so)
undefined symbol: __cxa_pure_virtual    (./libmpichcxx.so)
undefined symbol: __gxx_personality_v0  (./libmpichcxx.so)
undefined symbol: _ZdaPv        (./libmpichcxx.so)
undefined symbol: _Znwm (./libmpichcxx.so)
undefined symbol: _ZdlPv        (./libmpichcxx.so)
undefined symbol: _Znam (./libmpichcxx.so)
undefined symbol: __cxa_allocate_exception      (./libmpichcxx.so)
undefined symbol: __cxa_throw   (./libmpichcxx.so)

Comment 2 Fedora Update System 2011-08-27 07:16:59 UTC
mpich2-1.4.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mpich2-1.4.1-1.fc15

Comment 3 Jayesh Badwaik 2011-08-27 09:31:49 UTC
i can confirm that the update works for me...... 
the errors have been resolved...
thank you

Comment 4 Fedora Update System 2011-08-31 01:39:53 UTC
Package mpich2-1.4.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mpich2-1.4.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mpich2-1.4.1-1.fc15
then log in and leave karma (feedback).

Comment 5 Jayesh Badwaik 2011-08-31 15:42:28 UTC
can i leave multiple karma to speed up the process? 
or do three different users have to leave the karma?

Comment 6 Deji Akingunola 2011-08-31 15:56:34 UTC
I think we would need three different users to give it positive karma.

Or we can just wait for the minimum 7 days to get it pushed to stable.

Comment 7 Fedora Update System 2011-09-13 05:53:42 UTC
mpich2-1.4.1p1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.