Bug 733185

Summary: Grub2 fails to install bootloader on partition
Product: [Fedora] Fedora Reporter: Erinn Looney-Triggs <erinn.looneytriggs>
Component: grub2Assignee: Lubomir Rintel <lkundrak>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: dennis, lkundrak, pjones
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-26 04:09:08 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Erinn Looney-Triggs 2011-08-25 04:19:13 UTC
Description of problem:
grub2 fails to install the bootloader on a partition, for instance /dev/sda3. I use the windows bootloader to allow windows to work with a TPM and bitlocker. This forces me to install grub on a partition, this option appears in the f16 installer however it fails. When run from the command line in a chroot it too fails, throwing an "error: will not proceed with blocklists". 

Either blocklists are too dangerous to be used and thus the install option should be disabled, or they should be allowed and the install should work, though these two issues may not be one and the same in their root cause. 

Version-Release number of selected component (if applicable):

grub2-1.99-0.2.fc16.x86_64

Comment 1 Erinn Looney-Triggs 2011-08-26 04:09:08 UTC

*** This bug has been marked as a duplicate of bug 728742 ***