Bug 733213

Summary: KeyError: <pyanaconda.yuminstall.AnacondaYumRepo object at 0x7fe60321bf50>
Product: [Fedora] Fedora Reporter: mail <mail>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: anaconda-maint-list, jonathan, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:ba7f2b0d6f0ead4bccd6b4c423c5f55c75df13d539097c5bcc5cfaa55044a294
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-08-25 13:21:23 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description mail@romal.de 2011-08-25 07:21:11 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.0.0-1.fc16.x86_64
product:        Fedora
reason:         KeyError: <pyanaconda.yuminstall.AnacondaYumRepo object at 0x7fe60321bf50>
time:           Thu Aug 25 09:20:45 2011
version:        16-Alpha

description:
:The following was filed automatically by anaconda:
:anaconda 16.14.6 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 233, in _sql_MD
:    cache = getattr(self.sack, MD + 'db')[self.repo]
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
:    return func(*args, **kwargs)
:  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 388, in returnPrco
:    cur = self._sql_MD('primary', sql, (self.pkgKey,))
:  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 899, in _delPackageFromIndex
:    for (n, fl, (e,v,r)) in obj.returnPrco('conflicts'):
:  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 913, in delPackage
:    self._delPackageFromIndex(obj)
:  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 303, in remove
:    self._inSack.delPackage(txmbr.po)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1382, in resetPackageSelections
:    self.ayum.tsInfo.remove(txmbr.pkgtup)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 213, in doBasePackageSelect
:    anaconda.backend.resetPackageSelections()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 348, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 235, in go_forward
:    self.dispatch()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1198, in nextClicked
:    self.anaconda.dispatch.go_forward()
:KeyError: <pyanaconda.yuminstall.AnacondaYumRepo object at 0x7fe60321bf50>

Comment 1 Chris Lumens 2011-08-25 13:21:23 UTC

*** This bug has been marked as a duplicate of bug 622376 ***