Bug 733615

Summary: pkg build dependency check does not work
Product: [Fedora] Fedora Reporter: Thomas Sailer <t.sailer>
Component: octaveAssignee: Rakesh Pandit <rakesh.pandit>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: alexl, mmahut, orion, susi.lehtola
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-12 00:18:52 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Thomas Sailer 2011-08-26 09:34:56 UTC
Description of problem:

When trying to build:

I get:
error: the following dependencies where unsatisfied:
   optim needs miscellaneous >= 1.0.11
 optim needs struct >= 1.0.9

Even though:

are installed.

The octave-optim spec file uses the RPM macro %octave_pkg_build, which expands to:
octave -H -q --no-site-file --eval 'pkg build '\''-verbose'\'' /var/tmp/octave-optim-1.0.16-2.fc17.x86_64 /home/sailer/rpmbuild/BUILD/optim-1.0.16'

Version-Release number of selected component (if applicable):
(though this bug is not specific to rawhide, it's reproducible on F15 as well)

How reproducible:

Steps to Reproduce:
1.wget http://sailer.fedorapeople.org/octave-optim-1.0.16-2.fc15.src.rpm
2.rpmbuild --rebuild octave-optim-1.0.16-2.fc15.src.rpm
Actual results:
error: the following dependencies where unsatisfied:
   optim needs miscellaneous >= 1.0.11
 optim needs struct >= 1.0.9

Expected results:
successfully built octave-optim binary package

Comment 1 Orion Poplawski 2011-08-29 16:17:06 UTC
Works fine for me with:


Rawhide scratch build http://koji.fedoraproject.org/koji/taskinfo?taskID=3309487 built fine.  F15 build roots might not be up to date at the moment.  Should be once the recent octave updates are pushed to stable which should be soon.

Comment 2 Susi Lehtola 2011-08-29 16:54:37 UTC
I am 99% sure I commented on this issue and closed this yesterday. The problem was that I had accidentally done a buildroot override for octave-3.4.2-1.fc1{5,6} instead of octave-3.4.2-2.fc1{5,6}.

So, even though octave-3.4.2-2.fc16 was already in F16 stable, the buildroot override took preference, and compiling extensions didn't work in 3.4.2-1.

I succcesfully rebuild octave-optim yesterday after correcting the override.

Comment 3 Thomas Sailer 2011-11-28 18:25:03 UTC
Still does not work for me, see

Comment 4 Orion Poplawski 2012-12-22 04:17:29 UTC
I think I've found the problem.  In the pkg build code, install() is called is such a way a to be completely impossible to test the package deps yet it is being requested to do so.  For now I'm patching build() to call install and telling it not check deps.

As I understand it, upstream is looking to do a major rewrite of the pkg functions so hopefully this will get addressed.

Comment 5 Fedora Update System 2012-12-22 15:58:46 UTC
octave-3.6.3-2.fc18.2 has been submitted as an update for Fedora 18.

Comment 6 Fedora Update System 2012-12-22 21:09:07 UTC
Package octave-3.6.3-2.fc18.2:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing octave-3.6.3-2.fc18.2'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-01-12 00:18:54 UTC
octave-3.6.3-2.fc18.2 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.